aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:08:08 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:31 -0700
commitb6c8de6e017feb5b92815b5635cdb28eedc396dc (patch)
treea63279ea72fa1f2921817e4452339beec2558a52 /configure.ac
parent21f5ed4a2593a285068dca713aa1f861e558a113 (diff)
downloadmpd-b6c8de6e017feb5b92815b5635cdb28eedc396dc.tar.gz
mpd-b6c8de6e017feb5b92815b5635cdb28eedc396dc.tar.xz
mpd-b6c8de6e017feb5b92815b5635cdb28eedc396dc.zip
configure.ac: Move tremor/oggflac test under oggflac.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 333a27669..64d21dce9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1069,18 +1069,20 @@ fi
if test x$use_tremor = xyes; then
AC_DEFINE(HAVE_TREMOR,1,
[Define to use tremor (libvorbisidec) for ogg support])
- if test x$enable_oggflac = xyes; then
- AC_MSG_WARN([disabling OggFLAC support because it is incompatible with tremor])
- enable_oggflac=no
- fi
fi
AC_SUBST(TREMOR_CFLAGS)
AC_SUBST(TREMOR_LIBS)
dnl --------------------------------- OggFLAC ---------------------------------
-dnl OggFLAC must go after Ogg Tremor
-if test x$enable_oggflac = xyes; then
+dnl OggFLAC must go after Ogg Tremor
+
+if test x$use_tremor = xyes -a test $xenable_oggflac = yes; then
+ AC_MSG_WARN([disabling OggFLAC support because it is incompatible with tremor])
+ enable_oggflac=no
+fi
+
+if test x$enable_oggflac = xyes; then
oldmpdcflags="$MPD_CFLAGS"
oldmpdlibs="$MPD_LIBS"
AM_PATH_LIBOGGFLAC(MPD_LIBS="$MPD_LIBS $LIBOGGFLAC_LIBS"