aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 20:09:29 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:14 -0700
commit33641df09c8b4bd36ee1eff7c6e9651ece877848 (patch)
treefe8f2c9f8e90449148d0da397435771097059a9b /configure.ac
parent294cce2710560984c69bb79ee1f08900666fc09e (diff)
downloadmpd-33641df09c8b4bd36ee1eff7c6e9651ece877848.tar.gz
mpd-33641df09c8b4bd36ee1eff7c6e9651ece877848.tar.xz
mpd-33641df09c8b4bd36ee1eff7c6e9651ece877848.zip
configure.ac: Move OSS to Audio Output Plugins (nonstreaming), add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 10 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 4355149e3..e1e6a06c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -928,6 +928,16 @@ fi
AM_CONDITIONAL(HAVE_OPENAL, test x$enable_openal = xyes)
+dnl ---------------------------- Open Sound System ----------------------------
+if test x$enable_oss = xyes; then
+ AC_CHECK_HEADER(sys/soundcard.h,
+ [enable_oss=yes;AC_DEFINE(HAVE_OSS,1,[Define to enable OSS])],
+ [AC_MSG_WARN(Soundcard headers not found -- disabling OSS support);
+ enable_oss=no])
+fi
+
+AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
+
if test x$enable_pipe_output = xyes; then
AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
[Define to enable support for writing audio to a pipe])
@@ -975,14 +985,7 @@ esac
AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
-if test x$enable_oss = xyes; then
- AC_CHECK_HEADER(sys/soundcard.h,
- [enable_oss=yes;AC_DEFINE(HAVE_OSS,1,[Define to enable OSS])],
- [AC_MSG_WARN(Soundcard headers not found -- disabling OSS support);
- enable_oss=no])
-fi
-AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)