aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 20:08:27 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:14 -0700
commit294cce2710560984c69bb79ee1f08900666fc09e (patch)
treea0739662f9ad3513ebc79f2e221ad60c4a45bacb /configure.ac
parent9fb31aafb38f7f1f7babf8d7ab2360646151a72a (diff)
downloadmpd-294cce2710560984c69bb79ee1f08900666fc09e.tar.gz
mpd-294cce2710560984c69bb79ee1f08900666fc09e.tar.xz
mpd-294cce2710560984c69bb79ee1f08900666fc09e.zip
configure.ac: Move OpenAL to Audio Output Plugins (nonstreaming), add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 20 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 9ae73779b..4355149e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -906,7 +906,27 @@ fi
AM_CONDITIONAL(HAVE_AO, test x$enable_ao = xyes)
+dnl ---------------------------------- OpenAL ---------------------------------
+AC_SUBST(OPENAL_CFLAGS,"")
+AC_SUBST(OPENAL_LIBS,"")
+if test x$enable_openal = xyes; then
+ if test x$enable_osx = xyes; then
+ AC_CHECK_HEADERS([OpenAL/al.h OpenAL/alc.h], [], [enable_openal=no])
+ if test x$enable_openal = xyes; then
+ OPENAL_LIBS="-framework OpenAL"
+ AC_DEFINE(HAVE_OPENAL, 1, [Define for OpenAL support])
+ else
+ AC_MSG_WARN(OpenAL headers not found -- disabling OpenAL support)
+ fi
+ else
+ PKG_CHECK_MODULES([OPENAL], [openal],
+ AC_DEFINE(HAVE_OPENAL, 1, [Define for OpenAL support]),
+ enable_openal=no)
+ fi
+fi
+
+AM_CONDITIONAL(HAVE_OPENAL, test x$enable_openal = xyes)
if test x$enable_pipe_output = xyes; then
AC_DEFINE([ENABLE_PIPE_OUTPUT], 1,
@@ -964,26 +984,7 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
-AC_SUBST(OPENAL_CFLAGS,"")
-AC_SUBST(OPENAL_LIBS,"")
-if test x$enable_openal = xyes; then
- if test x$enable_osx = xyes; then
- AC_CHECK_HEADERS([OpenAL/al.h OpenAL/alc.h], [], [enable_openal=no])
- if test x$enable_openal = xyes; then
- OPENAL_LIBS="-framework OpenAL"
- AC_DEFINE(HAVE_OPENAL, 1, [Define for OpenAL support])
- else
- AC_MSG_WARN(OpenAL headers not found -- disabling OpenAL support)
- fi
- else
- PKG_CHECK_MODULES([OPENAL], [openal],
- AC_DEFINE(HAVE_OPENAL, 1, [Define for OpenAL support]),
- enable_openal=no)
- fi
-fi
-
-AM_CONDITIONAL(HAVE_OPENAL, test x$enable_openal = xyes)