aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 11:13:37 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 12:23:37 -0700
commit20bc25cdcc3abb42513ba541c80fb7cdb8415540 (patch)
tree1ce99e126f45dc125e0750979fe7f9bdb0703834 /configure.ac
parent13c07883342a4c3cb9ecdbe1907f9a424dcff2d1 (diff)
downloadmpd-20bc25cdcc3abb42513ba541c80fb7cdb8415540.tar.gz
mpd-20bc25cdcc3abb42513ba541c80fb7cdb8415540.tar.xz
mpd-20bc25cdcc3abb42513ba541c80fb7cdb8415540.zip
configure.ac: Move audio output tests to Post Audio Output Plugins section.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 19 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 513e52aef..2a3239f5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1367,6 +1367,25 @@ if test x$enable_shout = xyes; then
fi
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
+dnl --------------------- Post Audio Output Plugins Tests ---------------------
+if
+ test x$enable_ao = xno &&
+ test x$enable_oss = xno &&
+ test x$enable_openal = xno &&
+ test x$enable_shout = xno &&
+ test x$enable_recorder_output = xno &&
+ test x$enable_httpd_output = xno &&
+ test x$enable_solaris_output = xno &&
+ test x$enable_alsa = xno &&
+ test x$enable_osx = xno &&
+ test x$enable_pulse = xno &&
+ test x$enable_jack = xno &&
+ test x$enable_fifo = xno &&
+ test x$enable_pipe_output = xno &&
+ test x$enable_mvp = xno; then
+ AC_MSG_ERROR([No Audio Output types configured!])
+fi
+
dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------
@@ -1501,24 +1520,6 @@ echo -ne '\n\t'
results(solaris, [Solaris])
if
- test x$enable_ao = xno &&
- test x$enable_oss = xno &&
- test x$enable_openal = xno &&
- test x$enable_shout = xno &&
- test x$enable_recorder_output = xno &&
- test x$enable_httpd_output = xno &&
- test x$enable_solaris_output = xno &&
- test x$enable_alsa = xno &&
- test x$enable_osx = xno &&
- test x$enable_pulse = xno &&
- test x$enable_jack = xno &&
- test x$enable_fifo = xno &&
- test x$enable_pipe_output = xno &&
- test x$enable_mvp = xno; then
- AC_MSG_ERROR([No Audio Output types configured!])
-fi
-
-if
test x$enable_shout = xyes ||
test x$enable_recorder = xyes ||
test x$enable_httpd_output = xyes; then