aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:11:55 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:31 -0700
commit1cd5700c3772fdea0a7d3ffc70b8c8efe8d4c958 (patch)
tree2a5bebad161f5fff0ba6cd2efc97976cb9ef1ef2 /configure.ac
parent957cf3c7b02df7c8c337109fae7c00737fb458fd (diff)
downloadmpd-1cd5700c3772fdea0a7d3ffc70b8c8efe8d4c958.tar.gz
mpd-1cd5700c3772fdea0a7d3ffc70b8c8efe8d4c958.tar.xz
mpd-1cd5700c3772fdea0a7d3ffc70b8c8efe8d4c958.zip
configure.ac: Move FLAC Encoder to Encoder Plugins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d30367208..8d2bb8998 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,6 +1207,13 @@ else
enable_flac_encoder=no
fi
+dnl ------------------------------- FLAC Encoder ------------------------------
+if test x$enable_flac_encoder = xyes; then
+ AC_DEFINE(ENABLE_FLAC_ENCODER, 1,
+ [Define to enable the FLAC encoder plugin])
+fi
+AM_CONDITIONAL(ENABLE_FLAC_ENCODER, test x$enable_flac_encoder = xyes)
+
MPD_AUTO_PKG(vorbis_encoder, VORBISENC, [vorbisenc],
[Ogg Vorbis encoder], [libvorbisenc not found])
@@ -1325,12 +1332,6 @@ if test x$enable_wave_encoder = xyes; then
[Define to enable the PCM wave encoder plugin])
fi
-AM_CONDITIONAL(ENABLE_FLAC_ENCODER, test x$enable_flac_encoder = xyes)
-if test x$enable_flac_encoder = xyes; then
- AC_DEFINE(ENABLE_FLAC_ENCODER, 1,
- [Define to enable the FLAC encoder plugin])
-fi
-
dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------