aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:18:12 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:32 -0700
commit1aa470e0bfe653b0270a4909ce5ce25f1cce2ae7 (patch)
tree13a6f9351d580ac43fd29a87a41eeccbcdc4856c /configure.ac
parentb6a33691ff7a42e00d548de50a9e965d57987e18 (diff)
downloadmpd-1aa470e0bfe653b0270a4909ce5ce25f1cce2ae7.tar.gz
mpd-1aa470e0bfe653b0270a4909ce5ce25f1cce2ae7.tar.xz
mpd-1aa470e0bfe653b0270a4909ce5ce25f1cce2ae7.zip
configure.ac: Move WAVE Encoder to Encoder Plugins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3aebbfad6..fa6f6c0b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1258,6 +1258,13 @@ if test x$enable_twolame_encoder = xyes; then
fi
AM_CONDITIONAL(ENABLE_TWOLAME_ENCODER, test x$enable_twolame_encoder = xyes)
+dnl ------------------------------- WAVE Encoder ------------------------------
+AM_CONDITIONAL(ENABLE_WAVE_ENCODER, test x$enable_wave_encoder = xyes)
+if test x$enable_wave_encoder = xyes; then
+ AC_DEFINE(ENABLE_WAVE_ENCODER, 1,
+ [Define to enable the PCM wave encoder plugin])
+fi
+
if test x$enable_vorbis_encoder != xno ||
test x$enable_lame_encoder != xno ||
test x$enable_twolame_encoder != xno ||
@@ -1329,12 +1336,6 @@ if test x$enable_encoder = xyes; then
[Define to enable the encoder plugins])
fi
-AM_CONDITIONAL(ENABLE_WAVE_ENCODER, test x$enable_wave_encoder = xyes)
-if test x$enable_wave_encoder = xyes; then
- AC_DEFINE(ENABLE_WAVE_ENCODER, 1,
- [Define to enable the PCM wave encoder plugin])
-fi
-
dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------