aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-14 17:23:00 +0200
committerMax Kellermann <max@duempel.org>2008-10-14 17:23:00 +0200
commite9ed10de3a19356f6ea0f99f939cae12e436e4e8 (patch)
tree4431b03ffe3bfa355f0fd5d74b9dac32ffd3daee /configure.ac
parentb0c1cf75901796177d75c08ec950609c135f50b0 (diff)
downloadmpd-e9ed10de3a19356f6ea0f99f939cae12e436e4e8.tar.gz
mpd-e9ed10de3a19356f6ea0f99f939cae12e436e4e8.tar.xz
mpd-e9ed10de3a19356f6ea0f99f939cae12e436e4e8.zip
configure.ac: added --enable-debug, --enable-werror, --enable-profile
Add more configure options which control how MPD is compiled. --enable-debug is always enabled, until there is a stable release.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b152b7fc..2d207e7b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,19 @@ if test -z "$prefix" || test "x$prefix" = xNONE; then
done
fi
+AC_ARG_ENABLE(werror,
+ AS_HELP_STRING([--enable-werror],
+ [Treat warnings as errors (default: disabled)]),
+ [ENABLE_WERROR=$enableval], [ENABLE_WERROR=no])
+AC_ARG_ENABLE(debug,
+ AS_HELP_STRING([--enable-debug],
+ [Enable debugging (default: disabled)]),
+ [ENABLE_DEBUG=$enableval], [ENABLE_DEBUG=no])
+AC_ARG_ENABLE(gprof,
+ AS_HELP_STRING([--enable-gprof],
+ [Enable profiling via gprof (default: disabled)]),
+ [ENABLE_GPROF=$enableval], [ENABLE_GPROF=no])
+
AC_ARG_ENABLE(ao,[ --enable-ao enable support for libao (default: disable)],[enable_ao=$enableval],[enable_ao=no])
AC_ARG_ENABLE(shout_ogg,[ --disable-shout_ogg disable support for ogg streaming through shout (default: enable)],[enable_shout_ogg=$enableval],[enable_shout_ogg=yes])
AC_ARG_ENABLE(shout_mp3,[ --disable-shout_mp3 disable support for mp3 streaming through shout (default: enable)],[enable_shout_mp3=$enableval],[enable_shout_mp3=yes])
@@ -681,6 +694,24 @@ fi
dnl
+dnl build options
+dnl
+
+if test "x$ENABLE_WERROR" = xyes; then
+ MPD_CFLAGS="$MPD_CFLAGS -Werror -pedantic-errors"
+fi
+
+#if test "x$ENABLE_DEBUG" = xno; then
+ # don't set NDEBUG for now, until MPD is stable
+ #MPD_CFLAGS="$MPD_CFLAGS -DNDEBUG"
+#fi
+
+if test "x$ENABLE_GPROF" = xyes; then
+ MPD_CFLAGS="$MPD_CFLAGS -pg"
+fi
+
+
+dnl
dnl CFLAGS
dnl