aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-01 22:44:28 +0200
committerMax Kellermann <max@duempel.org>2009-04-01 22:44:28 +0200
commite2ca6b156e5167796da58802530954645a559b26 (patch)
tree268b867519d3089dc56a1baf75cacc3b9e51aff7 /configure.ac
parent8fe27203102d0d4c66e2933ed9f224ee636d6b37 (diff)
downloadmpd-e2ca6b156e5167796da58802530954645a559b26.tar.gz
mpd-e2ca6b156e5167796da58802530954645a559b26.tar.xz
mpd-e2ca6b156e5167796da58802530954645a559b26.zip
configure.ac: renamed --enable-lame to --enable-lame-encoder
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index b6e0d7d02..df38feb37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -520,10 +520,10 @@ AC_ARG_ENABLE(oggvorbis-encoder,
[enable support for ogg streaming]),,
[enable_oggvorbis_encoder=auto])
-AC_ARG_ENABLE(lame,
- AS_HELP_STRING([--enable-lame],
- [disable support for mp3 streaming]),,
- enable_lame=auto)
+AC_ARG_ENABLE(lame-encoder,
+ AS_HELP_STRING([--enable-lame-encoder],
+ [enable the LAME mp3 encoder]),,
+ enable_lame_encoder=auto)
dnl
@@ -950,22 +950,23 @@ else
# don't bother to check for encoder plugins
enable_oggvorbis_encoder=no
- enable_lame=no
+ enable_lame_encoder=no
fi
MPD_AUTO_PKG(oggvorbis_encoder, VORBISENC, [vorbisenc],
[Ogg Vorbis encoder], [libvorbisenc not found])
-if test x$enable_lame != xno; then
- AM_PATH_LAME([found_lame=yes], [found_lame=no])
- MPD_AUTO_RESULT(lame, [LAME encoder plugin],
+if test x$enable_lame_encoder != xno; then
+ AM_PATH_LAME([found_lame_encoder=yes], [found_lame_encoder=no])
+ MPD_AUTO_RESULT(lame_encoder, [LAME encoder plugin],
[LAME not found])
fi
AC_SUBST(LAME_CFLAGS)
AC_SUBST(LAME_LIBS)
-if test x$enable_oggvorbis_encoder != xno || test x$enable_lame != xno; then
+if test x$enable_oggvorbis_encoder != xno ||
+ test x$enable_lame_encoder != xno; then
# at least one encoder plugin is enabled
enable_encoder=yes
else
@@ -1015,8 +1016,8 @@ if test x$enable_oggvorbis_encoder = xyes; then
[Define to enable the vorbis encoder plugin])
fi
-AM_CONDITIONAL(ENABLE_LAME_ENCODER, test x$enable_lame = xyes)
-if test x$enable_lame = xyes; then
+AM_CONDITIONAL(ENABLE_LAME_ENCODER, test x$enable_lame_encoder = xyes)
+if test x$enable_lame_encoder = xyes; then
AC_DEFINE(ENABLE_LAME_ENCODER, 1,
[Define to enable the lame encoder plugin])
fi
@@ -1239,7 +1240,7 @@ if
test x$enable_shout = xyes ||
test x$enable_httpd_output = xyes; then
echo " Streaming Encoder Support:"
- if test x$enable_lame = xyes; then
+ if test x$enable_lame_encoder = xyes; then
echo " LAME mp3 encoder ..............enabled"
else
echo " LAME mp3 encoder ..............disabled"