aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-16 09:55:10 +0100
committerMax Kellermann <max@duempel.org>2009-03-16 09:55:10 +0100
commitbba127a392486be31961e82fe577de1a8caa8e5c (patch)
tree81834316cad21a87a25c71c0362839b89517f693 /configure.ac
parent18cb4fa277c97c3d52cc784bb94dc931b1d74f08 (diff)
downloadmpd-bba127a392486be31961e82fe577de1a8caa8e5c.tar.gz
mpd-bba127a392486be31961e82fe577de1a8caa8e5c.tar.xz
mpd-bba127a392486be31961e82fe577de1a8caa8e5c.zip
solaris: new audio output plugin for Solaris /dev/audio
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed9703fed..cd14c42f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -594,6 +594,20 @@ if test x$enable_shout = xyes; then
enable_shout=no)
fi
+case "$host_os" in
+ solaris*)
+ AC_DEFINE(ENABLE_SOLARIS_OUTPUT, 1, [Define to enable Solaris /dev/audio support])
+ enable_solaris_output=yes
+ ;;
+
+ *)
+ enable_solaris_output=no
+ ;;
+esac
+echo "HOST_OS=$host_os"
+
+AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
+
if test x$enable_oggvorbis_encoder = xyes; then
if test x$enable_oggvorbis = xno; then
AC_MSG_WARN([disabling ogg shout streaming support because vorbis is not enabled])
@@ -1144,6 +1158,12 @@ else
echo " SHOUTcast support .............disabled"
fi
+if test x$enable_solaris_output = xyes; then
+ echo " Solaris /dev/audio support ....enabled"
+else
+ echo " Solaris /dev/audio support ....disabled"
+fi
+
echo ""
if
@@ -1151,6 +1171,7 @@ if
test x$enable_oss = xno &&
test x$enable_shout = xno &&
test x$enable_httpd_output = xno &&
+ test x$enable_solaris_output = xno &&
test x$enable_alsa = xno &&
test x$enable_osx = xno &&
test x$enable_pulse = xno &&