aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-07 15:50:19 +0100
committerMax Kellermann <max@duempel.org>2009-03-07 15:50:19 +0100
commit9ed409cdcc0b5f31f71be713074cded52d5ddb6b (patch)
treef6af02697b7508c266b44376f8171da97a4ef6f0 /configure.ac
parent55b0fed293c4e5866a9e10cea841689fbe710050 (diff)
downloadmpd-9ed409cdcc0b5f31f71be713074cded52d5ddb6b.tar.gz
mpd-9ed409cdcc0b5f31f71be713074cded52d5ddb6b.tar.xz
mpd-9ed409cdcc0b5f31f71be713074cded52d5ddb6b.zip
configure.ac: fix --enable-X variable names
The patch "remove redundant explicit $enableval assignments" broke several options with non-standard variable names.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b9788311b..206241f15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -993,18 +993,18 @@ dnl
AC_ARG_ENABLE(werror,
AS_HELP_STRING([--enable-werror],
[treat warnings as errors (default: disabled)]),,
- ENABLE_WERROR=no)
+ enable_werror=no)
-if test "x$ENABLE_WERROR" = xyes; then
+if test "x$enable_werror" = xyes; then
AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
fi
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging (default: disabled)]),,
- ENABLE_DEBUG=no)
+ enable_debug=no)
-#if test "x$ENABLE_DEBUG" = xno; then
+#if test "x$enable_debug" = xno; then
# don't set NDEBUG for now, until MPD is stable
#AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
#fi
@@ -1012,9 +1012,9 @@ AC_ARG_ENABLE(debug,
AC_ARG_ENABLE(gprof,
AS_HELP_STRING([--enable-gprof],
[enable profiling via gprof (default: disabled)]),,
- ENABLE_GPROF=no)
+ enable_gprof=no)
-if test "x$ENABLE_GPROF" = xyes; then
+if test "x$enable_gprof" = xyes; then
MPD_CFLAGS="$MPD_CFLAGS -pg"
fi