aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-25 20:59:36 +0200
committerMax Kellermann <max@duempel.org>2008-10-25 20:59:36 +0200
commit1110a6d41032d94dc5a7801ed02d82df5d31a0dc (patch)
treeb81a8c4a0ba9cf9ff4ab65a249871833fae8ca76 /configure.ac
parenta02db572919c7b7c21e023f45d3d11feaae4f54e (diff)
downloadmpd-1110a6d41032d94dc5a7801ed02d82df5d31a0dc.tar.gz
mpd-1110a6d41032d94dc5a7801ed02d82df5d31a0dc.tar.xz
mpd-1110a6d41032d94dc5a7801ed02d82df5d31a0dc.zip
removed internal copy of libmp4ff
MPD shouldn't integrate sources of other libraries. Since libmp4ff is part of libfaad, we should remove the old copy from src/mp4ff and link with the current version from libfaad instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 04b2b51c5..23c81aa18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,8 +8,6 @@ AC_CONFIG_MACRO_DIR([m4])
AC_SUBST(MPD_LIBS)
AC_SUBST(MPD_CFLAGS)
-AC_SUBST(MP4FF_LIB)
-AC_SUBST(MP4FF_SUBDIR)
dnl Remove the check for c++ and fortran compiler
m4_defun([_LT_AC_LANG_CXX_CONFIG], [:])
@@ -486,8 +484,6 @@ fi
AM_CONDITIONAL(HAVE_WAVPACK, test x$enable_wavpack = xyes)
-MP4FF_SUBDIR=""
-
if test x$enable_aac = xyes; then
if test "x$faad_libraries" != "x" ; then
FAAD_LIBS="-L$faad_libraries"
@@ -495,7 +491,7 @@ if test x$enable_aac = xyes; then
FAAD_LIBS="-L$faad_prefix/lib"
fi
- FAAD_LIBS="$FAAD_LIBS -lfaad"
+ FAAD_LIBS="$FAAD_LIBS -lfaad -lmp4ff"
if test "x$faad_includes" != "x" ; then
FAAD_CFLAGS="-I$faad_includes"
@@ -517,10 +513,10 @@ if test x$enable_aac = xyes; then
AC_CHECK_DECL(faacDecInit2,,enable_aac=no,[#include <faad.h>])
fi
if test x$enable_aac = xyes; then
- AC_CHECK_LIB(faad,faacDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ AC_CHECK_LIB(faad,faacDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS"],enable_aac=no)
if test x$enable_aac = xno; then
enable_aac=yes
- AC_CHECK_LIB(faad,NeAACDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ AC_CHECK_LIB(faad,NeAACDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS"],enable_aac=no)
fi
fi
if test x$enable_aac = xyes; then
@@ -799,7 +795,7 @@ dnl generate files
dnl
-AC_OUTPUT(src/mp4ff/Makefile doc/Makefile src/Makefile Makefile )
+AC_OUTPUT(doc/Makefile src/Makefile Makefile)
dnl