aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKalle Wallin <kaw@linux.se>2004-03-19 13:26:18 +0000
committerKalle Wallin <kaw@linux.se>2004-03-19 13:26:18 +0000
commita0592c8cc08b802f86061c88dc6862352b6c3e94 (patch)
treefeda87ba55a404023e62b8d744e2667dccebdc95 /configure.ac
downloadmpd-a0592c8cc08b802f86061c88dc6862352b6c3e94.tar.gz
mpd-a0592c8cc08b802f86061c88dc6862352b6c3e94.tar.xz
mpd-a0592c8cc08b802f86061c88dc6862352b6c3e94.zip
Imported ncmpc (mpc-ncures).
git-svn-id: https://svn.musicpd.org/ncmpc/trunk@292 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac100
1 files changed, 100 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 000000000..0b39bec4a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,100 @@
+dnl
+dnl $Id: configure.ac,v 1.10 2004/03/18 09:33:43 kalle Exp $
+dnl
+
+AC_INIT(main.c)
+AM_INIT_AUTOMAKE(mpc-ncurses, 0.1.2)
+
+dnl Check for programs
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+
+dnl =======================================================
+dnl initialize variables
+dnl =======================================================
+
+set -- $CFLAGS
+CFLAGS="-Wall $CFLAGS"
+
+
+dnl
+dnl Check for libaries
+dnl
+
+dnl ncurses
+AC_CHECK_LIB(ncurses, initscr,, [AC_MSG_ERROR(ncurses library is required)])
+
+dnl glib-2.0
+AM_PATH_GLIB_2_0(, , [AC_MSG_ERROR(glib-2.x is required)], glib)
+
+dnl popt
+AC_CHECK_LIB(popt,
+ poptGetArg,
+ LIBS="$LIBS -lpopt",
+ AC_MSG_ERROR(Missing popt command line parsing library))
+
+dnl
+dnl Check for types
+dnl
+AC_CHECK_TYPE(socklen_t,
+ AC_DEFINE(HAVE_SOCKLEN_T, 1, socklen_t defined in sys/socket.h),
+)
+
+dnl
+dnl Check for headers
+dnl
+AC_CHECK_HEADER(libgen.h,
+ AC_DEFINE(HAVE_LIBGEN_H, 1, glibc - libgen.h),
+ ,)
+
+dnl
+dnl X11
+dnl
+dnl AC_PATH_XTRA
+
+dnl Debugging
+AC_ARG_ENABLE(debug,
+ [ --enable-debug Enable debugging [default=no]],
+ ,
+ enable_debug=no)
+
+if test "$enable_debug" = yes; then
+ CFLAGS="$CFLAGS -g -DDEBUG"
+fi
+
+dnl Default host
+AC_ARG_WITH(default-host,
+ [ --with-default-host=HOST Default host (localhost)],
+ DEFAULT_HOST="$withval",
+ DEFAULT_HOST="localhost")
+
+dnl Default port
+AC_ARG_WITH(default-port,
+ [ --with-default-port=PORT Default port (2100)],
+ DEFAULT_PORT="$withval",
+ DEFAULT_PORT="2100")
+
+
+CFLAGS="$CFLAGS $GLIB_CFLAGS"
+LIBS="$LIBS $GLIB_LIBS -lncurses"
+
+
+dnl Autoheader
+AC_DEFINE_UNQUOTED(DEFAULT_PORT, $DEFAULT_PORT, Default MPD port)
+AC_DEFINE_UNQUOTED(DEFAULT_PORT_STR, "$DEFAULT_PORT", Default MPD port)
+AC_DEFINE_UNQUOTED(DEFAULT_HOST, "$DEFAULT_HOST", Default MPD host)
+
+
+AM_CONFIG_HEADER(config.h)
+
+AC_OUTPUT(Makefile)
+
+echo "
+Configuration:
+ Install path: ${prefix}
+ Enable debugging: ${enable_debug}
+ Default MPD host: ${DEFAULT_HOST}
+ Default MPD port: ${DEFAULT_PORT}
+"
+echo