aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-03 14:25:00 +0200
committerMax Kellermann <max@duempel.org>2008-10-03 14:25:00 +0200
commit88af2c3ace0fa42dbb816cc9fe8c4b54ce89233a (patch)
treef637ddd9f06c52890ffffe4910d410d4dd36d520 /configure.ac
parent3e70743f5061573a2d9fff2fe4b232f38653d12b (diff)
downloadmpd-88af2c3ace0fa42dbb816cc9fe8c4b54ce89233a.tar.gz
mpd-88af2c3ace0fa42dbb816cc9fe8c4b54ce89233a.tar.xz
mpd-88af2c3ace0fa42dbb816cc9fe8c4b54ce89233a.zip
colors: make color support optional at compile time
Default is colors disabled. Those who love colorful terminals have the option to enable it with --enable-colors.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 732b36f1e..83a47a7d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,6 +138,18 @@ if test "x$use_raw" = "xyes" ; then
AC_DEFINE([ENABLE_RAW_MODE], [1], [Place the terminal into raw mode])
fi
+dnl enable colors
+AC_MSG_CHECKING([color support])
+AC_ARG_ENABLE([colors],
+ AC_HELP_STRING([--enable-colors],
+ [Enable color support]),
+ [use_colors=$enableval],
+ [use_colors=no])
+AC_MSG_RESULT([$use_colors])
+if test "x$use_colors" = "xyes" ; then
+ AC_DEFINE([ENABLE_COLORS], [1], [Enable color support])
+fi
+
dnl Debugging
AC_MSG_CHECKING([whether to build with debug support])
AC_ARG_ENABLE([debug],