aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-11-07 08:25:51 +0100
committerMax Kellermann <max@duempel.org>2008-11-07 08:25:51 +0100
commit865a07f6753c23190a18c1a1429be144bf7069b2 (patch)
tree0a8c8126ee4df94fb7f6511dfeb742aea96ba502 /configure.ac
parent51f0ed166508442b65c0fb4ec46da685607608a2 (diff)
downloadmpd-865a07f6753c23190a18c1a1429be144bf7069b2.tar.gz
mpd-865a07f6753c23190a18c1a1429be144bf7069b2.tar.xz
mpd-865a07f6753c23190a18c1a1429be144bf7069b2.zip
configure.ac: added --disable-nls
Option --disable-nls disables all NLS features, even if the system supports it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4dec85891..212b618e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,19 @@ fi
dnl i18n
+
+AC_MSG_CHECKING([national language support])
+AC_ARG_ENABLE([nls],
+ AS_HELP_STRING([--enable-nls], [Enable national language support]),
+ [enable_nls=$enableval],
+ [enable_nls=$disable_mini])
+AC_MSG_RESULT([$enable_nls])
+
+if test "x$enable_nls" = xno; then
+ glib24=no
+ nls=no
+fi
+
AM_NLS
if test "x$glib24" = "xyes"; then
nls=$USE_NLS