aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJ. Alexander Treuman <jat@spatialrift.net>2007-06-03 19:44:19 +0000
committerJ. Alexander Treuman <jat@spatialrift.net>2007-06-03 19:44:19 +0000
commitd5596a1cf09ba5f89ab59824de19d15fcaceb8aa (patch)
tree1107de6a7aacf6529952f53632ea12ad402d2bbd /configure.ac
parentab14f8a3c7a85c289ea8a664ba95a618aee59a67 (diff)
downloadmpd-d5596a1cf09ba5f89ab59824de19d15fcaceb8aa.tar.gz
mpd-d5596a1cf09ba5f89ab59824de19d15fcaceb8aa.tar.xz
mpd-d5596a1cf09ba5f89ab59824de19d15fcaceb8aa.zip
Define HAVE_ZEROCONF if Avahi or Bonjour support is enabled, so that we can
silence a warning about an unused variable without using stupid checks for HAVE_AVAHI || HAVE_BONJOUR. git-svn-id: https://svn.musicpd.org/mpd/trunk@6471 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e5fd32fae..2e00d4bb9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -601,7 +601,7 @@ if test x$with_zeroconf != xno; then
if test x$with_zeroconf = xbonjour || test x$with_zeroconf = xauto; then
AC_CHECK_HEADER(dns_sd.h,
- [found_bonjour=1;AC_DEFINE(HAVE_BONJOUR, 1, [Define to enable Bonjour Zeroconf support])],
+ [found_bonjour=1;AC_DEFINE([HAVE_BONJOUR], 1, [Define to enable Bonjour Zeroconf support])],
[found_bonjour=0])
AC_CHECK_LIB(dns_sd, DNSServiceRegister,
MPD_LIBS="$MPD_LIBS -ldns_sd")
@@ -616,6 +616,8 @@ if test x$with_zeroconf != xno; then
if test x$with_zeroconf = xauto || test x$with_zeroconf = xno; then
AC_MSG_WARN([No supported Zeroconf backend found, disabling Zeroconf])
with_zeroconf=no
+ else
+ AC_DEFINE([HAVE_ZEROCONF], 1, [Define to enable Zeroconf support])
fi
fi