aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-08-26 08:27:02 +0200
committerEric Wong <normalperson@yhbt.net>2008-08-30 17:38:50 -0700
commitac5ec35a6e222f635912f6a7eaf3c036c71367b6 (patch)
treecb6d1ec7b4b5d165b61da5b27e717c52b1b3f5c6 /configure.ac
parent2147b207c03891bd657043766444006dce513a93 (diff)
downloadmpd-ac5ec35a6e222f635912f6a7eaf3c036c71367b6.tar.gz
mpd-ac5ec35a6e222f635912f6a7eaf3c036c71367b6.tar.xz
mpd-ac5ec35a6e222f635912f6a7eaf3c036c71367b6.zip
enable -Wpointer-arith, -Wstrict-prototypes
Also enable -Wunused-parameter - this forces us to add the gcc "unused" attribute to a lot of parameters (mostly library callback functions), but it's worth it during code refactorizations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6067bc480..5630fe650 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,11 +26,12 @@ if test x$GCC = xyes
then
MPD_CHECK_FLAG([-Wall])
MPD_CHECK_FLAG([-Wextra])
- MPD_CHECK_FLAG([-Wno-unused-parameter])
MPD_CHECK_FLAG([-Wno-deprecated-declarations])
MPD_CHECK_FLAG([-Wmissing-prototypes])
MPD_CHECK_FLAG([-Wdeclaration-after-statement])
MPD_CHECK_FLAG([-Wshadow])
+ MPD_CHECK_FLAG([-Wpointer-arith])
+ MPD_CHECK_FLAG([-Wstrict-prototypes])
fi
if test -z "$prefix" || test "x$prefix" = xNONE; then