aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-09-02 02:12:21 -0700
committerEric Wong <normalperson@yhbt.net>2008-09-02 02:12:57 -0700
commita420911adce13025c5032c118c0b4f49d3ca3ad9 (patch)
treea7d2efbc3a4ca10b7a4300d0b7c197811a42f36d /configure.ac
parentd8262eb1a178b6bb5ad6fca60c44c1357a933d2e (diff)
downloadmpd-a420911adce13025c5032c118c0b4f49d3ca3ad9.tar.gz
mpd-a420911adce13025c5032c118c0b4f49d3ca3ad9.tar.xz
mpd-a420911adce13025c5032c118c0b4f49d3ca3ad9.zip
build: enable -Wcast-qual -Wwrite-strings CFLAGS
We're pretty careful about using const these days, so enable these warnings to keep us that way.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5630fe650..c3db4cbc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,8 @@ then
MPD_CHECK_FLAG([-Wshadow])
MPD_CHECK_FLAG([-Wpointer-arith])
MPD_CHECK_FLAG([-Wstrict-prototypes])
+ MPD_CHECK_FLAG([-Wcast-qual])
+ MPD_CHECK_FLAG([-Wwrite-strings])
fi
if test -z "$prefix" || test "x$prefix" = xNONE; then