aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-10-05 19:11:28 -0700
committerEric Wong <normalperson@yhbt.net>2008-10-05 19:13:48 -0700
commit84a4c6e2651916c65f317a52534dbf08529c5bed (patch)
tree37a88163e9140258e662e8c3ac6fcb8c048be7ce /configure.ac
parent2a669f4a1169e193fbaad873d5e3ae3b268453db (diff)
downloadmpd-84a4c6e2651916c65f317a52534dbf08529c5bed.tar.gz
mpd-84a4c6e2651916c65f317a52534dbf08529c5bed.tar.xz
mpd-84a4c6e2651916c65f317a52534dbf08529c5bed.zip
autotools: add pthreads linker support
This is needed for people that don't use any of the following: JACK, ALSA, libmikmod, Shout.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fdfe0e2ed..4ca85b443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,10 @@ dnl AC_CHECK_HEADER(langinfo.h,[enable_langinfo=yes;AC_DEFINE(HAVE_LANGINFO,1,[D
AM_LANGINFO_CODESET
AC_CHECK_HEADER(locale.h,[enable_locale=yes;AC_DEFINE(HAVE_LOCALE,1,[Define if locale.h is present])],enable_locale=no)
+ACX_PTHREAD([CC="$PTHREAD_CC"
+ LIBS="$PTHREAD_LIBS $LIBS"
+ CFLAGS="$PTHREAD_CFLAGS $CFLAGS"])
+
if test x$enable_tcp = xno; then
# if we don't support TCP, we don't need IPv6 either
enable_ipv6=no