aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-05-11 16:16:52 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-05-11 16:16:52 +0000
commit4db513dddb5d1ff61cd5ad18a2f2b85ca8aded20 (patch)
tree423d446bfb603f9a7ceb01b9c343d323165ca5cc /configure.ac
parent011757d89cd16f8f0277578e1c0bd87009f1d58b (diff)
downloadmpd-4db513dddb5d1ff61cd5ad18a2f2b85ca8aded20.tar.gz
mpd-4db513dddb5d1ff61cd5ad18a2f2b85ca8aded20.tar.xz
mpd-4db513dddb5d1ff61cd5ad18a2f2b85ca8aded20.zip
check for main in libiconv, cause it doesn't define iconv_open, but libiconv_open
git-svn-id: https://svn.musicpd.org/mpd/trunk@991 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b6b9c0c72..c7dab52e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,7 +150,7 @@ if test x$enable_iconv = xyes; then
CPPFLAGS=$CFLAGS
AC_CHECK_HEADER(iconv.h,MPD_CFLAGS="$MPD_CFLAGS $ICONV_CFLAGS",enable_iconv=no)
if test x$enable_iconv = xyes; then
- AC_CHECK_LIB(iconv,iconv_open,MPD_LIBS="$MPD_LIBS $ICONV_LIBS",)
+ AC_CHECK_LIB(iconv,main,MPD_LIBS="$MPD_LIBS $ICONV_LIBS",)
AC_DEFINE(HAVE_ICONV,1,[Define to use iconv])
fi
CFLAGS=$oldcflags