aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJ. Alexander Treuman <jat@spatialrift.net>2006-12-17 23:42:36 +0000
committerJ. Alexander Treuman <jat@spatialrift.net>2006-12-17 23:42:36 +0000
commit469ff630932ce2ca0fa4874c5a8bff7fa2ead025 (patch)
treeffc3dedb126f0f64fb24fcc9fd851511480a7b3a /configure.ac
parent0435a8c7c1e53a0f97358097979680de94cb985b (diff)
downloadmpd-469ff630932ce2ca0fa4874c5a8bff7fa2ead025.tar.gz
mpd-469ff630932ce2ca0fa4874c5a8bff7fa2ead025.tar.xz
mpd-469ff630932ce2ca0fa4874c5a8bff7fa2ead025.zip
Do PKG_PROG_PKG_CONFIG if either pulse or jack is enabled. This is because
if you don't explicitly call it, then it is implied by the first use of PKG_CHECK_MODULES (and no later ones). This results in the check only being done in the test for pulse, which is skipped when --disable-pulse is used. This will fix the bug mentioned in the previous commit. git-svn-id: https://svn.musicpd.org/mpd/trunk@5142 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76b05baa4..f8aee7a4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,6 +177,10 @@ if test x$enable_oss = xyes; then
AC_CHECK_HEADER(sys/soundcard.h,[enable_oss=yes;AC_DEFINE(HAVE_OSS,1,[Define to enable OSS])],[AC_MSG_WARN(Soundcard headers not found -- disabling OSS support);enable_oss=no])
fi
+if test x$enable_pulse = xyes || test x$enable_jack = xyes; then
+ PKG_PROG_PKG_CONFIG
+fi
+
if test x$enable_pulse = xyes; then
PKG_CHECK_MODULES([PULSE], [libpulse-simple],
[enable_pulse=yes;AC_DEFINE([HAVE_PULSE], 1, [Define to enable PulseAudio support])] MPD_LIBS="$MPD_LIBS $PULSE_LIBS" MPD_CFLAGS="$MPD_CFLAGS $PULSE_CFLAGS",