aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJ. Alexander Treuman <jat@spatialrift.net>2007-06-03 00:03:20 +0000
committerJ. Alexander Treuman <jat@spatialrift.net>2007-06-03 00:03:20 +0000
commit4025498488edc9e405abe21dc633b48911dcd1d9 (patch)
tree7881db919231b20296ecd92f194c611bb2092244 /configure.ac
parente41601c98b6fa261cc82379062f11510a41ae4e0 (diff)
downloadmpd-4025498488edc9e405abe21dc633b48911dcd1d9.tar.gz
mpd-4025498488edc9e405abe21dc633b48911dcd1d9.tar.xz
mpd-4025498488edc9e405abe21dc633b48911dcd1d9.zip
Cleaning up zeroconf configure magic.
git-svn-id: https://svn.musicpd.org/mpd/trunk@6464 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 15 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index dd03ef773..e5fd32fae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -586,33 +586,34 @@ no|avahi|bonjour)
esac
if test x$with_zeroconf != xno; then
- if test x$with_zeroconf = xavahi -o x$with_zeroconf = xauto; then
+ if test x$with_zeroconf = xavahi || test x$with_zeroconf = xauto; then
PKG_CHECK_MODULES([AVAHI], [avahi-client],
- [found_avahi=1;AC_DEFINE([HAVE_AVAHI], 1, [Define to enable Avahi Zeroconf support])] MPD_LIBS="$MPD_LIBS $AVAHI_LIBS" MPD_CFLAGS="$MPD_CFLAGS $AVAHI_CFLAGS", found_avahi=0)
+ [found_avahi=1;AC_DEFINE([HAVE_AVAHI], 1, [Define to enable Avahi Zeroconf support])]
+ MPD_LIBS="$MPD_LIBS $AVAHI_LIBS" MPD_CFLAGS="$MPD_CFLAGS $AVAHI_CFLAGS",
+ [found_avahi=0])
fi
if test x$found_avahi = x1; then
with_zeroconf=avahi
- else
- if test x$with_zeroconf = xavahi; then
- with_zeroconf=no
- fi
+ elif test x$with_zeroconf = xavahi; then
+ with_zeroconf=no
fi
- if test x$with_zeroconf = xbonjour -o x$with_zeroconf = xauto; then
- AC_CHECK_HEADER(dns_sd.h, [found_bonjour=1;AC_DEFINE(HAVE_BONJOUR,1,[Define to enable Bonjour Zeroconf support])],[found_bonjour=0])
- AC_CHECK_LIB(dns_sd, DNSServiceRegister, MPD_LIBS="$MPD_LIBS -ldns_sd")
+ if test x$with_zeroconf = xbonjour || test x$with_zeroconf = xauto; then
+ AC_CHECK_HEADER(dns_sd.h,
+ [found_bonjour=1;AC_DEFINE(HAVE_BONJOUR, 1, [Define to enable Bonjour Zeroconf support])],
+ [found_bonjour=0])
+ AC_CHECK_LIB(dns_sd, DNSServiceRegister,
+ MPD_LIBS="$MPD_LIBS -ldns_sd")
fi
if test x$found_bonjour = x1; then
with_zeroconf=bonjour
- else
- if test x$with_zeroconf = xbonjour; then
- with_zeroconf=no
- fi
+ elif test x$with_zeroconf = xbonjour; then
+ with_zeroconf=no
fi
- if test x$with_zeroconf = xauto -o x$with_zeroconf = xno; then
+ if test x$with_zeroconf = xauto || test x$with_zeroconf = xno; then
AC_MSG_WARN([No supported Zeroconf backend found, disabling Zeroconf])
with_zeroconf=no
fi