aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2009-03-16 08:44:41 +0100
committerMax Kellermann <max@duempel.org>2009-03-16 08:44:41 +0100
commitf1fb4e99a63c8982b6f2a5712365eeb58bb41472 (patch)
treef38cbfe5bb23fbeaf3cdb28d719fea74db80b7e6 /configure.ac
parent04b092bbfe418bd38e782add174b08fad6f8058c (diff)
downloadmpd-f1fb4e99a63c8982b6f2a5712365eeb58bb41472.tar.gz
mpd-f1fb4e99a63c8982b6f2a5712365eeb58bb41472.tar.xz
mpd-f1fb4e99a63c8982b6f2a5712365eeb58bb41472.zip
configure: Always run pkg-config for shout, define AC_DEFINE if enabled
[mk: don't run pkg-config when shout is disabled]
Diffstat (limited to '')
-rw-r--r--configure.ac15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 58a1ad15d..094189058 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,10 +593,10 @@ AC_ARG_ENABLE(shout,
[enables the shoutcast streaming output (default: disable)]),,
[enable_shout=no])
-if test x$enable_oggvorbis_encoder = xyes || test x$enable_lame_encoder = xyes; then
- PKG_CHECK_MODULES([SHOUT], [shout],,
- [enable_oggvorbis_encoder=no; enable_lame_encoder=no;
- AC_MSG_WARN([disabling shout streaming support because libshout is not available])])
+if test x$enable_shout = xyes; then
+ PKG_CHECK_MODULES([SHOUT], [shout],
+ AC_DEFINE(HAVE_SHOUT, 1, [Define to enable libshout support]),
+ enable_shout=no)
fi
if test x$enable_oggvorbis_encoder = xyes; then
@@ -628,13 +628,6 @@ if test x$enable_lame_encoder = xyes; then
fi
fi
-if test x$enable_oggvorbis_encoder = xyes || test x$enable_lame_encoder = xyes; then
- enable_shout=yes
- AC_DEFINE(HAVE_SHOUT, 1, [Define to enable libshout support])
-else
- enable_shout=no
-fi
-
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
AM_CONDITIONAL(ENABLE_ENCODER, test x$enable_shout = xyes || test x$enable_httpd_output = xyes)