aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Jansen <mithi@mithi.net>2008-11-07 08:16:41 +0100
committerMax Kellermann <max@duempel.org>2008-11-07 08:16:41 +0100
commitd88a1718bbca660e13ad60f8f1aec6084fcf7788 (patch)
tree808e721f1fffeafa4a9fa6e169e5467ae3dd28f3 /configure.ac
parent8221502e87f6c1a652b7c3148467248f538970bd (diff)
downloadmpd-d88a1718bbca660e13ad60f8f1aec6084fcf7788.tar.gz
mpd-d88a1718bbca660e13ad60f8f1aec6084fcf7788.tar.xz
mpd-d88a1718bbca660e13ad60f8f1aec6084fcf7788.zip
native LIRC support for ncmpc
The attachment includes the patch and a sample .lircrc config for testing purposes (i. e. only a few commands are mapped to IR events). The config is rather simple to write: For each button add a block like this to ~/.lircrc: begin button = <button name from /etc/lircd.conf> prog = ncmpc config = <command name from src/command.c> end The patch is not finished, there are several problems that still need to be solved: 1. the configure.ac modifications are just for testing purposes and should be made optional with a parameter like --enable-lirc for ./configure. Unfortunately I'm not an expert on autoconfig tools. 2. LIRC example code [1] suggests looping over lirc_code2char, probably to have multiple actions that can be triggered from one button. Perhaps lirc_event(...) should be moved to lirc.c and be heavily modified, no longer being a mere copy of keyboard_event(...).
Diffstat (limited to '')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8611c0da4..d46045fc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,6 +174,11 @@ if test "x$use_colors" = "xyes" ; then
AC_DEFINE([ENABLE_COLORS], [1], [Enable color support])
fi
+dnl test for LIRC support
+AC_CHECK_LIB(lirc_client, lirc_init)
+AC_SUBST(LIRC_LIBS)
+AC_DEFINE([ENABLE_LIRC], [1], [Enable LIRC support])
+
dnl Debugging
AC_MSG_CHECKING([whether to build with debug support])
AC_ARG_ENABLE([debug],