aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-30 19:17:07 +0100
committerMax Kellermann <max@duempel.org>2013-10-30 19:17:07 +0100
commitc8b2591ac23d251c2eeae554f67c9c956e0f9c89 (patch)
tree13cd50d87b78444ba2a791bc07a90819dc89093d /configure.ac
parentee1d8e10918d6fc05efee80fa2c94bad4cea848e (diff)
downloadmpd-c8b2591ac23d251c2eeae554f67c9c956e0f9c89.tar.gz
mpd-c8b2591ac23d251c2eeae554f67c9c956e0f9c89.tar.xz
mpd-c8b2591ac23d251c2eeae554f67c9c956e0f9c89.zip
configure.ac: move -Werror before all other CFLAGS
Without -Werror, clang will not fail on -ftree-vectorize.
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cf8dce7ac..0b1baad62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1463,6 +1463,13 @@ dnl ---------------------------------------------------------------------------
dnl CFLAGS
dnl ---------------------------------------------------------------------------
+dnl ---------------------------- warnings as errors ---------------------------
+if test "x$enable_werror" = xyes; then
+ CFLAGS="$CFLAGS -Werror -pedantic-errors"
+ CXXFLAGS="$CXXFLAGS -Werror"
+fi
+
+dnl ---------------------------- language features ----------------------------
AX_APPEND_COMPILE_FLAGS([-fvisibility=hidden])
AX_APPEND_COMPILE_FLAGS([-ffast-math])
AX_APPEND_COMPILE_FLAGS([-ftree-vectorize])
@@ -1517,12 +1524,6 @@ then
AC_LANG_POP
fi
-dnl ---------------------------- warnings as errors ---------------------------
-if test "x$enable_werror" = xyes; then
- AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
- AM_CXXFLAGS="$AM_CXXFLAGS -Werror"
-fi
-
dnl ---------------------------------------------------------------------------
dnl Pretty-Print Results
dnl ---------------------------------------------------------------------------