aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Dawson <mike@gp2x.org>2009-08-30 19:49:04 +0200
committerMax Kellermann <max@duempel.org>2009-08-30 19:49:04 +0200
commitcde9408bd883e6ea67c9c2ced3f928bc9c044eb5 (patch)
treeb24bbdba511ea13dcf25612907b6a6a7a37d639f /configure.ac
parent85ce9aa7deec29d8b3b3dffeaa4a46e1090693f5 (diff)
downloadmpd-cde9408bd883e6ea67c9c2ced3f928bc9c044eb5.tar.gz
mpd-cde9408bd883e6ea67c9c2ced3f928bc9c044eb5.tar.xz
mpd-cde9408bd883e6ea67c9c2ced3f928bc9c044eb5.zip
decoder/sidplay: implemented songlength database
[mk: added autoconf test; fixed songlen_data_size type]
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 681feae6c..e730c6977 100644
--- a/configure.ac
+++ b/configure.ac
@@ -554,12 +554,17 @@ if test x$enable_sidplay != xno; then
# library name triggers an autoconf bug
AC_CHECK_LIB(resid-builder, main,
[found_sidplay=yes], [found_sidplay=no])
+
+ if test x$found_sidplay = xyes; then
+ AC_HAVE_LIBRARY(sidutils,, [found_sidplay=no])
+ fi
+
MPD_AUTO_RESULT(sidplay, [sidplay decoder plugin],
- [libresid-builder not found])
+ [libresid-builder or libsidutils not found])
fi
if test x$enable_sidplay = xyes; then
- AC_SUBST(SIDPLAY_LIBS,"-lsidplay2 -lresid-builder")
+ AC_SUBST(SIDPLAY_LIBS,"-lsidplay2 -lresid-builder -lsidutils")
AC_SUBST(SIDPLAY_CFLAGS,)
AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])