aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2008-10-06 18:52:48 +0200
committerMax Kellermann <max@duempel.org>2008-10-06 18:52:48 +0200
commita792dc5b933c1314ddf9d5c33844a7e016ad32d4 (patch)
treee70dd2ec60c6fc00216c862c7523d37034bb69b3 /configure.ac
parent09c78663c7afb95a1cc0b40afd6993448ca11278 (diff)
downloadmpd-a792dc5b933c1314ddf9d5c33844a7e016ad32d4.tar.gz
mpd-a792dc5b933c1314ddf9d5c33844a7e016ad32d4.tar.xz
mpd-a792dc5b933c1314ddf9d5c33844a7e016ad32d4.zip
autotools: add pthreads linker support
This is needed for people that don't use any of the following: JACK, ALSA, libmikmod, Shout.
Diffstat (limited to '')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 451858f74..78925d469 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,6 +148,10 @@ dnl AC_CHECK_HEADER(langinfo.h,[enable_langinfo=yes;AC_DEFINE(HAVE_LANGINFO,1,[D
AM_LANGINFO_CODESET
AC_CHECK_HEADER(locale.h,[enable_locale=yes;AC_DEFINE(HAVE_LOCALE,1,[Define if locale.h is present])],enable_locale=no)
+ACX_PTHREAD([CC="$PTHREAD_CC"
+ LIBS="$PTHREAD_LIBS $LIBS"
+ CFLAGS="$PTHREAD_CFLAGS $CFLAGS"])
+
if test x$enable_tcp = xno; then
# if we don't support TCP, we don't need IPv6 either
enable_ipv6=no