aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-16 19:11:40 +0200
committerMax Kellermann <max@duempel.org>2008-09-16 19:11:40 +0200
commitf41b9942af7278ab67dc799ad6c17ad74dc0aa1b (patch)
tree69c7c715ff3abd78bb26a7a4d80dd1da5fd5c08b /configure.ac
parent4d01c183b4c1e4c51dff3d9aeec1c01ce13a4323 (diff)
downloadmpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.tar.gz
mpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.tar.xz
mpd-f41b9942af7278ab67dc799ad6c17ad74dc0aa1b.zip
lyrics: converted in-process plugins to external programs
In-process plugins are very problematic. It is much easier and flexible to move the lyrics plugins to external programs, with a trivial protocol. This is work in progress, among the things missing: - protocol specification, including exit codes - plugin installation - plugin search directory - run-time configuration (currently hard coded) - automatic polling (using glib's main loop?) - better and more robust error handling
Diffstat (limited to '')
-rw-r--r--configure.ac125
1 files changed, 1 insertions, 124 deletions
diff --git a/configure.ac b/configure.ac
index 8382c32cb..9c0fd9dfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,35 +134,6 @@ PKG_CHECK_MODULES([GTHREAD],
AC_SUBST(GTHREAD_LIBS)
AC_SUBST(GTHREAD_CFLAGS)
-dnl check for gmodule
-PKG_CHECK_MODULES([GMODULE],
- [gmodule-2.0],
- [gmodule=yes],
- [AC_MSG_WARN([gmodule-2.0 >= 0.20 is required the plugin system])])
-AC_SUBST(GMODULE_LIBS)
-AC_SUBST(GMODULE_CFLAGS)
-
-dnl check for libcurl
-PKG_CHECK_MODULES([libcurl],
- [libcurl],
- [libcurl=yes],
- #[libcurl=yes,LIBS="$LIBS -lcurl"], #doesn't work for me on arch
- [AC_MSG_WARN([libcurl is required for the lyrics screen])])
-
-if test "x$libcurl" = "xyes"; then
- LIBS="$LIBS -lcurl"
-fi
-
-dnl check for expat
-expat=expat
-AC_CHECK_LIB([$expat],
- [XML_ParserCreate],
- [have_expat=yes],
- [AC_MSG_WARN($expat library is required for lyrics screen)])
-if test "x$have_expat" = "xyes"; then
-LIBS="$LIBS -l$expat"
-fi
-
#if test "x$gthread-2.0" != "xyes"; then
# PKG_CHECK_MODULES([GTHREAD],
# [glib-2.0 >= 2.2],
@@ -250,23 +221,6 @@ if test "x$getmouse" = "xyes" ; then
[])
fi
-dnl Plugin loading for lyrics sources
-AC_MSG_CHECKING([whether to include the plugin infrastructure])
-AC_ARG_ENABLE([plugin-support],
- AC_HELP_STRING([--enable-plugin-support],
- [Enable loading lyrics plugins @<:@default=yes@:>@]),
- [plugin_support="$enableval"],
- [plugin_support=yes])
-if test "x$plugin_support" != "xyes" ; then
- AC_DEFINE(DISABLE_PLUGIN_SYSTEM, 1, [Disable plugin system])
-fi
-
-if test "x$gmodule" != "xyes" ; then
- AC_DEFINE(DISABLE_PLUGIN_SYSTEM, 1, [Disable plugin system])
- plugin_support=no
-fi
-AC_MSG_RESULT([$plugin_support])
-
dnl Optional screen - artist
AC_MSG_CHECKING([whether to include the artist screen])
AC_ARG_ENABLE([artist-screen],
@@ -343,78 +297,6 @@ fi
AC_MSG_RESULT([$lyrics_screen])
-dnl hd
-AC_MSG_CHECKING([whether to build with .lyrics support])
-AC_ARG_WITH([lyrics-hd],
- AC_HELP_STRING([[--with-lyrics-leoslyrics[=plugin/fixed/no]]],
- [enable leoslyrics lyrics source @<:@default=plugin@:>@]),
- [hd=$withval],
- [hd=plugin])
-
-if test "x$plugin_support" != "xyes" ; then
- if test "x$hd" == "xplugin" ; then
- hd=fixed
- AC_MSG_NOTICE([Enable lyrics plugin support to compile as a plugin!])
- fi
-fi
-AC_MSG_RESULT([$hd])
-if test "x$hd" == "xfixed"; then
- AC_DEFINE_UNQUOTED([ENABLE_LYRSRC_HD], 1,
- [~/.lyrics inclusion])
-fi
-if test "x$hd" == "xplugin" ; then
- src_lyr_plugins="${src_lyr_plugins}hd "
-fi
-AM_CONDITIONAL(HD_FIXED, test x$hd = xfixed)
-
-dnl leoslyrics
-AC_MSG_CHECKING([whether to build with leoslyrics])
-AC_ARG_WITH([lyrics-leoslyrics],
- AC_HELP_STRING([[--with-lyrics-leoslyrics[=plugin/fixed/no]]],
- [enable leoslyrics lyrics source @<:@default=plugin@:>@]),
- [leoslyrics=$withval],
- [leoslyrics=plugin])
-
-if test "x$plugin_support" != "xyes" ; then
- if test "x$leoslyrics" == "xplugin" ; then
- leoslyrics=fixed
- AC_MSG_NOTICE([Enable lyrics plugin support to compile as a plugin!])
- fi
-fi
-
-if test "x$have_expat" != "xyes" ; then
- leoslyrics=no
-fi
-if test "x$libcurl" != "xyes" ; then
- leoslyrics=no
-fi
-
-if test "x$leoslyrics" == "xplugin" ; then
- src_lyr_plugins="${src_lyr_plugins}leoslyrics "
-fi
-AC_MSG_RESULT([$leoslyrics])
-
-if test "x$leoslyrics" == "xfixed" ; then
- AC_DEFINE_UNQUOTED([ENABLE_LYRSRC_LEOSLYRICS], 1,
- [Leoslyrics inclusion])
-fi
-
-#if test "x$leoslyrics" == "xfixed" ; then
- # src_lyr_fixed="${src_lyr_fixed}../plugins/leoslyrics/lyrics_leoslyrics.c "
- # leoslyrics_fixed=yes
-#fi
-AM_CONDITIONAL(LEOSLYRICS_FIXED, test x$leoslyrics = xfixed)
-
-dnl plugins directory
-AC_ARG_WITH([plugin-dir],
- AC_HELP_STRING([[--with-plugin-dir[=DIRECTORY]]],
- [Directory where plugins are stored @<:@default=/usr/share/ncmpc/modules@:>@]),
- [plugindir=$withval],
- [plugindir="/usr/share/ncmpc/modules"])
-AC_DEFINE_UNQUOTED([PLUGIN_DIR_SYSTEM], ["$plugindir"],
- [Directory to search for plugins])
-
-AC_SUBST(plugindir)
dnl Default host
AC_MSG_CHECKING([for default MPD host])
AC_ARG_WITH([default-host],
@@ -445,10 +327,5 @@ AC_ARG_WITH([default-timedisplay_type],
[DEFAULT_TIMEDISPLAY_TYPE="elapsed"])
AC_MSG_RESULT([$DEFAULT_TIMEDISPLAY_TYPE])
AC_DEFINE_UNQUOTED([DEFAULT_TIMEDISPLAY_TYPE], ["$DEFAULT_TIMEDISPLAY_TYPE"], [Default way to display time, either 'elapsed' or 'remaining'])
-AC_SUBST(src_lyr_plugins)
-AC_SUBST(src_lyr_fixed)
-AC_CONFIG_FILES([Makefile src/Makefile plugins/Makefile doc/Makefile po/Makefile
- plugins/hd/Makefile
- plugins/leoslyrics/Makefile])
+AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile po/Makefile])
AC_OUTPUT
-AC_MSG_WARN([TO BUILD AN INSTALL THE PLUGINS cd TO THE plugins DIRECTORY AND EXECUTE make && make install THERE])