aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-25 20:00:03 +0200
committerMax Kellermann <max@duempel.org>2008-09-25 20:00:03 +0200
commitcee4c0450e477e6b683fb3db883227c2a7fa423f (patch)
tree6d38e37ce065a8db8e7444fae5ab317cf97108f7 /configure.ac
parentf87fea3cd0792de52c0620c329b67db096a7a687 (diff)
downloadmpd-cee4c0450e477e6b683fb3db883227c2a7fa423f.tar.gz
mpd-cee4c0450e477e6b683fb3db883227c2a7fa423f.tar.xz
mpd-cee4c0450e477e6b683fb3db883227c2a7fa423f.zip
screen: don't compile disabled sources
Instead of evaluating macros from config.h in the disabled source, don't start the compiler on it at all.
Diffstat (limited to '')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ef9a617cd..4637c2555 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,6 +218,8 @@ if test "x$artist_screen" != "xyes" ; then
AC_DEFINE(DISABLE_ARTIST_SCREEN, 1, [Disable artist screen])
fi
+AM_CONDITIONAL(ENABLE_ARTIST_SCREEN, test x$artist_screen = xyes)
+
dnl Optional screen - search
AC_MSG_CHECKING([whether to include the search screen])
AC_ARG_ENABLE([search-screen],
@@ -229,6 +231,8 @@ AC_MSG_RESULT([$search_screen])
if test "x$search_screen" != "xyes" ; then
AC_DEFINE(DISABLE_SEARCH_SCREEN, 1, [Disable search screen])
fi
+
+AM_CONDITIONAL(ENABLE_SEARCH_SCREEN, test x$search_screen = xyes)
dnl Optional screen - key editor
AC_MSG_CHECKING([whether to include the key editor screen])
@@ -242,6 +246,8 @@ if test "x$keydef_screen" != "xyes" ; then
AC_DEFINE(DISABLE_KEYDEF_SCREEN, 1, [Disable key editor screen])
fi
+AM_CONDITIONAL(ENABLE_KEYDEF_SCREEN, test x$keydef_screen = xyes)
+
dnl Optional screen - lyrics
AC_MSG_CHECKING([whether to include the lyrics screen])
AC_ARG_ENABLE([lyrics-screen],
@@ -254,7 +260,7 @@ if test "x$lyrics_screen" != "xyes" ; then
lyrics_screen=no
fi
-AM_CONDITIONAL(LYRICS, test x$lyrics_screen = xyes)
+AM_CONDITIONAL(ENABLE_LYRICS_SCREEN, test x$lyrics_screen = xyes)
AC_MSG_RESULT([$lyrics_screen])