aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Obergrusberger <tradiaz@yahoo.de>2006-08-05 11:25:20 +0000
committerAndreas Obergrusberger <tradiaz@yahoo.de>2006-08-05 11:25:20 +0000
commita2ccb7365b8b20ad352a79611cba275506d93c7b (patch)
tree774bc010d69c6938ba86297d9b86e9a33c6cf08a /configure.ac
parent4cf9f458a9800e5a1be11e2a426cc0afb5283252 (diff)
downloadmpd-a2ccb7365b8b20ad352a79611cba275506d93c7b.tar.gz
mpd-a2ccb7365b8b20ad352a79611cba275506d93c7b.tar.xz
mpd-a2ccb7365b8b20ad352a79611cba275506d93c7b.zip
translation updates, template and german. another little build fix
git-svn-id: https://svn.musicpd.org/ncmpc/branches/tradiaz@4555 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3f8e222dc..e3e68eec1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,8 +143,13 @@ AC_SUBST(GTHREAD_CFLAGS)
dnl check for libcurl
PKG_CHECK_MODULES([libcurl],
[libcurl],
- [libcurl=yes,LIBS="$LIBS -lcurl"],
+ [libcurl=yes],
+ #[libcurl=yes,LIBS="$LIBS -lcurl"], #doesn't work for me on arch
[AC_MSG_WARN([libcurl is required for the lyrics screen])])
+
+if test "x$libcurl" = "xyes"; then
+ LIBS="$LIBS -lcurl"
+fi
dnl check for expat
expat=expat
@@ -287,12 +292,14 @@ if test "x$lyrics_screen" != "xyes" ; then
fi
#lyrics_screen=yes
if test "$libcurl" != "yes" ; then
- AC_DEFINE(DISABLE_LYRICS_SCREEN, 1, [Disable lyrics screen])
- lyrics_screen=no
+ AC_MSG_RESULT([$lyrics_screen])
+ # AC_DEFINE(DISABLE_LYRICS_SCREEN, 1, [Disable lyrics screen])
+ # lyrics_screen=no
fi
if test "$gthread" != "yes" ; then
AC_DEFINE(DISABLE_LYRICS_SCREEN, 1, [Disable lyrics screen])
lyrics_screen=no
+AC_MSG_RESULT([$lyrics_screen])
fi
if test "$have_expat" != "yes" ; then
AC_DEFINE(DISABLE_LYRICS_SCREEN, 1, [Disable lyrics screen])