aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-15 12:27:28 +0200
committerMax Kellermann <max@duempel.org>2008-09-15 12:27:28 +0200
commit4ebba1b36f4f171fb5daa25a8578e21d2740c517 (patch)
treed65b86318939ce111bf855539aa4d1b3e2bc581b /configure.ac
parent7d98fb19dc2b7c3af289b0a7c1a0db68e7fea8c9 (diff)
downloadmpd-4ebba1b36f4f171fb5daa25a8578e21d2740c517.tar.gz
mpd-4ebba1b36f4f171fb5daa25a8578e21d2740c517.tar.xz
mpd-4ebba1b36f4f171fb5daa25a8578e21d2740c517.zip
use !NDEBUG instead of DEBUG
NDEBUG is more commonly used than DEBUG, e.g. in assert.h. Convert all macros to NDEBUG, and declare NDEBUG when debugging is disabled.
Diffstat (limited to '')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 16a13571d..dc6a41351 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,7 +206,9 @@ AC_ARG_ENABLE([debug],
[enable_debug=no])
AC_MSG_RESULT([$enable_debug])
if test "x$enable_debug" = "xyes" ; then
- CFLAGS="$CFLAGS -g -DDEBUG"
+ CFLAGS="$CFLAGS -g"
+else
+ CFLAGS="$CFLAGS -DNDEBUG"
fi
dnl CFLAGS