aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMikael Svantesson <mikael@distopic.net>2008-12-05 18:35:56 +0100
committerMax Kellermann <max@duempel.org>2008-12-05 18:35:56 +0100
commit3cff7b547795bdeeea44dc54bc851e70bfc7b40f (patch)
tree6e8ef272c5b51ccce4eebb79d7a27d814467ce52 /configure.ac
parent785cb31333a8f0aaedf33af9cba38f012d514453 (diff)
downloadmpd-3cff7b547795bdeeea44dc54bc851e70bfc7b40f.tar.gz
mpd-3cff7b547795bdeeea44dc54bc851e70bfc7b40f.tar.xz
mpd-3cff7b547795bdeeea44dc54bc851e70bfc7b40f.zip
screen_outputs: new screen to control MPD's output devices
The "outputs" screen allows the user to enable or disable MPD's audio output devices.
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 806006e6b..e85570bd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -372,6 +372,19 @@ AC_DEFINE_UNQUOTED([LYRICS_PLUGIN_DIR], ["$lyrics_plugin_dir"],
[Directory to search for lyrics plugins])
AC_SUBST(lyrics_plugin_dir)
+dnl Optional screen - outputs
+AC_MSG_CHECKING([whether to include the outputs screen])
+AC_ARG_ENABLE([outputs-screen],
+ AC_HELP_STRING([--enable-outputs-screen],
+ [Enable outputs screen @<:@default=no@:>@]),
+ [outputs_screen=$enableval],
+ [outputs_screen=$disable_mini])
+if test "x$outputs_screen" = "xyes" ; then
+ AC_DEFINE(ENABLE_OUTPUTS_SCREEN, 1, [Enable outputs screen])
+fi
+
+AM_CONDITIONAL(ENABLE_OUTPUTS_SCREEN, test x$outputs_screen = xyes)
+
dnl Default host
AC_MSG_CHECKING([for default MPD host])
AC_ARG_WITH([default-host],