aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrée Ekroth <andree.ekroth@gmail.com>2014-08-07 19:52:56 +0200
committerAndrée Ekroth <andree.ekroth@gmail.com>2014-08-07 21:01:38 +0200
commit330b6a04822a49aec23a968061faac4f49a94afa (patch)
tree66a22e1ee97102516a959cb6f09af4b3a473a30a /Makefile.am
parentbbea6564fc454feb722241c4469ccbd0ce32aa01 (diff)
downloadmpd-330b6a04822a49aec23a968061faac4f49a94afa.tar.gz
mpd-330b6a04822a49aec23a968061faac4f49a94afa.tar.xz
mpd-330b6a04822a49aec23a968061faac4f49a94afa.zip
decoder/Mp4v2: add MP4v2 decoder plugin
This plugin uses the MP4v2 library to play mp4/m4a files. It is limited to file_decode.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 038b8db9b..dd0f1a3e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -796,6 +796,7 @@ libdecoder_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(WAVPACK_CFLAGS) \
$(MAD_CFLAGS) \
$(MPG123_CFLAGS) \
+ $(MP4V2_CFLAGS) \
$(OPUS_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(MPCDEC_CFLAGS) \
@@ -815,6 +816,7 @@ DECODER_LIBS = \
$(WAVPACK_LIBS) \
$(MAD_LIBS) \
$(MPG123_LIBS) \
+ $(MP4V2_LIBS) \
$(OPUS_LIBS) \
$(FFMPEG_LIBS) \
$(MPCDEC_LIBS) \
@@ -919,6 +921,12 @@ noinst_LIBRARIES += libmodplug_decoder_plugin.a
DECODER_LIBS += libmodplug_decoder_plugin.a $(MODPLUG_LIBS)
endif
+if HAVE_MP4V2
+libdecoder_a_SOURCES += \
+ src/decoder/plugins/Mp4v2DecoderPlugin.cxx \
+ src/decoder/plugins/Mp4v2DecoderPlugin.hxx
+endif
+
if ENABLE_SIDPLAY
libdecoder_a_SOURCES += \
src/decoder/plugins/SidplayDecoderPlugin.cxx \