aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrançois Revol <revol@free.fr>2014-08-01 22:07:33 +0200
committerMax Kellermann <max@duempel.org>2014-08-02 08:48:44 +0200
commit250318329f9e662bd7ee5f07af14f175a0b12eeb (patch)
tree4501c6f4f485647a0c5e1e10c89e5bf09bf6f647 /Makefile.am
parent14c538c9c73b23b807e5327399db6bb991c808bb (diff)
downloadmpd-250318329f9e662bd7ee5f07af14f175a0b12eeb.tar.gz
mpd-250318329f9e662bd7ee5f07af14f175a0b12eeb.tar.xz
mpd-250318329f9e662bd7ee5f07af14f175a0b12eeb.zip
Makefile.am: fix dependencies for win32
It happened to me when doing the Haiku port, src/mpd failed to be relinked properly when editing source files, and likely also happens on win32, although I didn't try this change. When building for windows, src_mpd_DEPENDENCIES is overriden. Automake then disables the default version which contains all the static libraries. In Makefile.in: @HAVE_WINDOWS_FALSE@src_mpd_DEPENDENCIES = libmpd.a \ Instead we use EXTRA_src_mpd_DEPENDENCIES which is meant for this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ef21ee23..6a5e9fb27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -217,7 +217,7 @@ src/win32/mpd_win32_rc.$(OBJEXT): src/win32/mpd_win32_rc.rc
if HAVE_WINDOWS
noinst_DATA = src/win32/mpd_win32_rc.rc
-src_mpd_DEPENDENCIES = src/win32/mpd_win32_rc.$(OBJEXT)
+EXTRA_src_mpd_DEPENDENCIES = src/win32/mpd_win32_rc.$(OBJEXT)
src_mpd_LDFLAGS = -Wl,src/win32/mpd_win32_rc.$(OBJEXT)
endif