aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-01 15:36:24 +0200
committerMax Kellermann <max@duempel.org>2009-04-01 15:36:24 +0200
commita3823c7657e486b371577e669c3171becb1678b7 (patch)
tree7e04d76f368c29c4cdbb3b12017d16664b3a335a /Makefile.am
parent85cecbddde93aa4bcb7821473ea95ccad150ce4c (diff)
parent4bfbdfe5c522011a695c804cfccf190eb4500e9a (diff)
downloadmpd-a3823c7657e486b371577e669c3171becb1678b7.tar.gz
mpd-a3823c7657e486b371577e669c3171becb1678b7.tar.xz
mpd-a3823c7657e486b371577e669c3171becb1678b7.zip
Merge branch 'master' of git://git.musicpd.org/jrk/mpd
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 34e46a87d..c11e8db11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,7 +152,8 @@ mpd_headers = \
src/archive_api.h \
src/archive_internal.h \
src/archive_list.h \
- src/input/archive_input_plugin.h
+ src/input/archive_input_plugin.h \
+ src/cue/cue_tag.h
src_mpd_SOURCES = \
$(mpd_headers) \
@@ -295,7 +296,8 @@ DECODER_CFLAGS = \
$(FLUIDSYNTH_CFLAGS) \
$(WILDMIDI_CFLAGS) \
$(MAD_CFLAGS) \
- $(FFMPEG_CFLAGS)
+ $(FFMPEG_CFLAGS) \
+ $(CUE_CFLAGS)
DECODER_LIBS = \
$(OGGVORBIS_LIBS) $(FLAC_LIBS) \
@@ -306,7 +308,8 @@ DECODER_LIBS = \
$(WILDMIDI_LIBS) \
$(MAD_LIBS) \
$(MP4FF_LIBS) \
- $(FFMPEG_LIBS)
+ $(FFMPEG_LIBS) \
+ $(CUE_LIBS)
DECODER_SRC = \
src/decoder_buffer.c \
@@ -415,6 +418,9 @@ src_mpd_SOURCES += src/zeroconf-bonjour.c
endif
endif
+if HAVE_CUE
+DECODER_SRC += src/cue/cue_tag.c
+endif
#
# input plugins