aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-23 13:15:42 +0200
committerMax Kellermann <max@duempel.org>2008-09-23 13:15:42 +0200
commit72ad9955c8d5c9abe28d8d59301e159493087976 (patch)
tree1a40e0e4808ec3e207b4022a0204f94b357ece1b /Makefile.am
parentca8a4cf4d050457f633edd13f0052e119629a9f6 (diff)
downloadmpd-72ad9955c8d5c9abe28d8d59301e159493087976.tar.gz
mpd-72ad9955c8d5c9abe28d8d59301e159493087976.tar.xz
mpd-72ad9955c8d5c9abe28d8d59301e159493087976.zip
lyrics: configurable global plugin directory
The lyrics library loads all plugins from the directory configured with "--with-lyrics-plugin-dir".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 456cb532c..419bd097c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,3 +18,14 @@ doc_DATA = \
EXTRA_DIST = \
$(doc_DATA)
+
+#
+# lyrics plugins
+#
+
+lyrics_plugin_dir = @lyrics_plugin_dir@
+lyrics_plugins = hd.py leoslyrics.py lyricswiki.rb
+
+install-exec-local:
+ install -m 0755 -d $(lyrics_plugin_dir)
+ install -m 0755 $(addprefix lyrics/,$(lyrics_plugins)) $(lyrics_plugin_dir)