aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-11-07 13:42:31 +0100
committerMax Kellermann <max@duempel.org>2008-11-07 13:42:31 +0100
commitb2617354f437ac905057f521b47b8be6c3addcd1 (patch)
tree0f468e9782d88a1c98212224a6f11e8122e812c6 /Makefile.am
parent9f05576990bca5fc8aeebe2fd84a11d78d87f72a (diff)
downloadmpd-b2617354f437ac905057f521b47b8be6c3addcd1.tar.gz
mpd-b2617354f437ac905057f521b47b8be6c3addcd1.tar.xz
mpd-b2617354f437ac905057f521b47b8be6c3addcd1.zip
Makefile.am: added custom rule with -fwhole-program
To make the ncmpc binary even smaller, you can compile all sources at once with "--combine -fwhole-program". Unfortunately, automake does not support this mode. For further experiments, this patch adds a custom rule which creates the binary named "ncmpc-tiny" this way.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b8469f3b..b0b2f4fc0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,10 @@ doc_DATA = \
EXTRA_DIST = \
$(doc_DATA)
+# build the smalles possible ncmpc binary
+ncmpc-tiny:
+ $(MAKE) -C src $@
+
sparse-check:
$(MAKE) -C src $@