aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-10-04 07:09:31 +0200
committerMax Kellermann <max@duempel.org>2012-10-04 10:37:09 +0200
commitb8fdb452be9d79492b4bff84d2990cfcb1da282b (patch)
tree5353ba8365f4d4e3b19bfc78241343eac2637954 /Makefile.am
parent6b416ce6be840dcd62aadb70817be602b5a73946 (diff)
downloadmpd-b8fdb452be9d79492b4bff84d2990cfcb1da282b.tar.gz
mpd-b8fdb452be9d79492b4bff84d2990cfcb1da282b.tar.xz
mpd-b8fdb452be9d79492b4bff84d2990cfcb1da282b.zip
decoder/flac: support FLAC files inside archives
Implement the "scan_stream" method that can read tags from any input_stream object. This requires a FLAC__IOCallbacks implementation based on the input_stream API.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 92ee671e4..3f462db45 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -620,6 +620,7 @@ endif
if HAVE_FLAC
libdecoder_plugins_a_SOURCES += \
src/decoder/FLACInput.cxx src/decoder/FLACInput.hxx \
+ src/decoder/FLACIOHandle.cxx src/decoder/FLACIOHandle.hxx \
src/decoder/FLACMetaData.cxx src/decoder/FLACMetaData.hxx \
src/decoder/FLAC_PCM.cxx src/decoder/FLAC_PCM.hxx \
src/decoder/FLACCommon.cxx src/decoder/FLACCommon.hxx \