aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2006-07-17 00:15:31 +0000
committerEric Wong <normalperson@yhbt.net>2006-07-17 00:15:31 +0000
commit0c24fc0cb33dd6482670a54ed80c7dc67ebc929c (patch)
tree86ca72346fd24d49d07c2b9d0ed52811b6359911 /Makefile.am
parente570f13d74805824cef4fa4ea0dcf746f36cc83a (diff)
downloadmpd-0c24fc0cb33dd6482670a54ed80c7dc67ebc929c.tar.gz
mpd-0c24fc0cb33dd6482670a54ed80c7dc67ebc929c.tar.xz
mpd-0c24fc0cb33dd6482670a54ed80c7dc67ebc929c.zip
add sparse-check target to makefiles
sparse is a semantic parser developed for the Linux kernel, but works for any project written (ANSI) C. You can get sparse via git here: git clone git://www.kernel.org/pub/scm/devel/sparse/sparse.git git-svn-id: https://svn.musicpd.org/mpd/trunk@4377 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d3ca4fb6..952d42762 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,5 +2,8 @@ AUTOMAKE_OPTIONS = foreign 1.6
SUBDIRS = src doc
docdir = $(prefix)/share/doc/$(PACKAGE)
-doc_DATA = README UPGRADING
+doc_DATA = README UPGRADING
EXTRA_DIST = COPYING $(doc_DATA)
+
+sparse-check:
+ $(MAKE) -C src $@