aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-09-15 09:45:53 +0200
committerMax Kellermann <max@duempel.org>2011-09-15 09:48:36 +0200
commitf2be6432a9bd7017ade806a74daa91254e128ce4 (patch)
treed42be7eecbc31afeba4a1df4ea7446dfafbb1b8b /Makefile.am
parente96f8c0444a2c9b9bd754164d7d04a61da34d232 (diff)
downloadmpd-f2be6432a9bd7017ade806a74daa91254e128ce4.tar.gz
mpd-f2be6432a9bd7017ade806a74daa91254e128ce4.tar.xz
mpd-f2be6432a9bd7017ade806a74daa91254e128ce4.zip
Makefile.am: allow out-of-tree sparse call
Diffstat (limited to '')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 60aab2c5e..e6f681766 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -879,8 +879,9 @@ SPARSE_CPPFLAGS = $(DEFAULT_INCLUDES) \
-I$(shell $(CC) -print-file-name=include-fixed)
SPARSE_CPPFLAGS += -D__SCHAR_MAX__=127 -D__SHRT_MAX__=32767 \
-D__INT_MAX__=2147483647 -D__LONG_MAX__=2147483647
+SPARSE_SOURCES = $(addprefix $(top_srcdir)/,$(filter %.c,$(src_mpd_SOURCES)))
sparse-check:
- $(SPARSE) -I. $(src_mpd_CFLAGS) $(src_mpd_CPPFLAGS) $(SPARSE_FLAGS) $(SPARSE_CPPFLAGS) $(filter-out %.cxx,$(src_mpd_SOURCES))
+ $(SPARSE) -I. $(src_mpd_CFLAGS) $(src_mpd_CPPFLAGS) $(SPARSE_FLAGS) $(SPARSE_CPPFLAGS) $(SPARSE_SOURCES)
.PHONY: sparse-check