aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index eb5af604..f7bb7919 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,34 @@ then
fi
AC_MSG_RESULT($version)
+# See if dnspython is installed.
+AC_MSG_CHECKING(dnspython)
+changequote(,)
+cat > conftest.py <<EOF
+try:
+ import dns.resolver
+ res = 'ok'
+except ImportError:
+ res = 'no'
+fp = open("conftest.out", "w")
+fp.write("%s\n" % res)
+fp.close()
+EOF
+changequote([, ])
+$PYTHON conftest.py
+havednspython=`cat conftest.out`
+rm -f conftest.out conftest.py
+if test "$havednspython" = "no"
+then
+ AC_MSG_ERROR([
+
+***** dnspython not found. It is required for the new
+***** dmarc_moderation_action featurer. Get it from
+***** <http://www.dnspython.org/> or
+***** <https://pypi.python.org/pypi/dnspython/>])
+fi
+AC_MSG_RESULT($havednspython)
+
# Check the email package version.
AC_MSG_CHECKING(Python's email package)
changequote(,)
@@ -194,7 +222,7 @@ else:
# some RedHat packages put distutils in python, but the C headers
# are in python-devel so check for headers too.
import os.path
- pdothpath = distutils.sysconfig.get_config_var('CONFINCLUDEPY')
+ pdothpath = distutils.sysconfig.get_python_inc()
if os.path.isfile(os.path.join(pdothpath, "Python.h")):
res = "yes"
else:
@@ -681,6 +709,7 @@ bin/b4b5-archfix \
bin/rb-archfix \
contrib/check_perms_grsecurity.py \
contrib/qmail-to-mailman.py \
+contrib/courier-to-mailman.py \
contrib/rotatelogs.py \
cron/bumpdigests \
cron/checkdbs \