aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ee55b96..f7bb7919 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,34 @@ then
fi
AC_MSG_RESULT($version)
+# See if dnspython is installed.
+AC_MSG_CHECKING(dnspython)
+changequote(,)
+cat > conftest.py <<EOF
+try:
+ import dns.resolver
+ res = 'ok'
+except ImportError:
+ res = 'no'
+fp = open("conftest.out", "w")
+fp.write("%s\n" % res)
+fp.close()
+EOF
+changequote([, ])
+$PYTHON conftest.py
+havednspython=`cat conftest.out`
+rm -f conftest.out conftest.py
+if test "$havednspython" = "no"
+then
+ AC_MSG_ERROR([
+
+***** dnspython not found. It is required for the new
+***** dmarc_moderation_action featurer. Get it from
+***** <http://www.dnspython.org/> or
+***** <https://pypi.python.org/pypi/dnspython/>])
+fi
+AC_MSG_RESULT($havednspython)
+
# Check the email package version.
AC_MSG_CHECKING(Python's email package)
changequote(,)