aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLindsay <fmouse@fmp.com>2018-01-06 16:13:00 -0600
committerLindsay <fmouse@fmp.com>2018-01-06 16:13:00 -0600
commit75c03ef2312398560c05800d35ffffe0fe15ef7e (patch)
treec0134257817301a6432b93ece4413dec76de18ce /configure.in
parent4199371d91101bba2c60e78ee428d646e0b6698f (diff)
downloadmailman2-75c03ef2312398560c05800d35ffffe0fe15ef7e.tar.gz
mailman2-75c03ef2312398560c05800d35ffffe0fe15ef7e.tar.xz
mailman2-75c03ef2312398560c05800d35ffffe0fe15ef7e.zip
Added contrib/mailman-config.py and changes to configure.in and
configure to support it. mailman-config.py is added to the build/contrib directory when configure is run, and when executed, emits, to stdout, a number of useful configuration options, including the option string provided to configure at build time. This is useful when updating Mailman 2, or when trying to synchronize a manual install of Mailman with a distribution's FHS.
Diffstat (limited to '')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f7bb7919..ead04a3a 100644
--- a/configure.in
+++ b/configure.in
@@ -23,6 +23,10 @@ AC_INIT(src/common.h)
# /usr/local/mailman is the default installation directory
AC_PREFIX_DEFAULT(/usr/local/mailman)
+CONFIGURE_OPTS=`echo $@`
+AC_SUBST(CONFIGURE_OPTS)
+BUILD_DATE=`date`
+AC_SUBST(BUILD_DATE)
# Check for Python! Better be found on $PATH
AC_MSG_CHECKING(for --with-python)
@@ -135,6 +139,17 @@ $PYTHON conftest.py
needemailpkg=`cat conftest.out`
rm -f conftest.out conftest.py
+cat > getver.py <<EOF
+from Mailman.Version import VERSION
+fp = open("getver.out", "w")
+fp.write("%s\n" % VERSION)
+fp.close()
+EOF
+$PYTHON getver.py
+MM_VERSION=`cat getver.out`
+rm -f getver.out getver.py
+AC_SUBST(MM_VERSION)
+
# Should we rely on Python's own email package or use the pre-packaged version?
AC_SUBST(EMAILPKG)
if test "$needemailpkg" = "ok"
@@ -711,6 +726,7 @@ contrib/check_perms_grsecurity.py \
contrib/qmail-to-mailman.py \
contrib/courier-to-mailman.py \
contrib/rotatelogs.py \
+contrib/mailman-config.py \
cron/bumpdigests \
cron/checkdbs \
cron/cull_bad_shunt \