aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f61c91d3..a61048f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,6 +263,16 @@ AC_SUBST_DEFINE(HAVE_LIBPCRE, $libpcre_HAVE)
# get libpcre library dir
PKG_VALUE([libpcre], [LIBDIR], [variable=libdir], [$libpcre_PKG],
[library dir (e.g. /usr/lib, /sw/lib, ...)])
+# we need the soname of the pcre library
+if test x"$libpcre_HAVE" = xyes; then
+ old_LIBS="$LIBS"
+ LIBS="-lpcre"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([],[])],
+ [libpcre_LIBNAME=`objdump -p "conftest$EXEEXT" | grep pcre | awk '{print $2}'` dnl '
+ AC_SUBST([libpcre_LIBNAME],[$libpcre_LIBNAME])],
+ [AC_MSG_ERROR([failed to link])])
+ LIBS="$old_LIBS"
+fi
# find portmixer
PKG_HAVE([portmixer], [portmixer], no)