aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2008-09-01 17:01:58 +0000
committertobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2008-09-01 17:01:58 +0000
commit2ab22bdad1415813a3e1df329640332702272fc0 (patch)
tree380c56fb3840936848b1c2a44ef8509b1f23b33c /configure.ac
parent2cfc26881d21532cb9cb456800d0b1738e183fe0 (diff)
downloadusdx-2ab22bdad1415813a3e1df329640332702272fc0.tar.gz
usdx-2ab22bdad1415813a3e1df329640332702272fc0.tar.xz
usdx-2ab22bdad1415813a3e1df329640332702272fc0.zip
- new configure/make layout:
- configure/main-makefile moved to root-dir - configure-script checked in (no need to call autogen.sh on first run) - autogen.sh, m4, install.sh etc. moved to dists/autogen/ - config.guess/sub for canonical builds - unit-tests moved to test - removed delphi subdir in portaudio/-mixer - COPYING.txt/AUTHORS.txt/... added - dists/delphi7/2005 added git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@1334 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to '')
-rw-r--r--configure.ac (renamed from src/configure.ac)70
1 files changed, 15 insertions, 55 deletions
diff --git a/src/configure.ac b/configure.ac
index 1152c1a1..a04d5a68 100644
--- a/src/configure.ac
+++ b/configure.ac
@@ -21,22 +21,14 @@ PACKAGE_IRC="#ultrastardx at quakenet.org"
AC_SUBST(PACKAGE_IRC)
# Specify a source-file so autoconf can check if the source-dir exists
-AC_CONFIG_SRCDIR(ultrastardx.dpr)
+AC_CONFIG_SRCDIR(src/ultrastardx.dpr)
-# This one is not used by autoconf at the moment.
-# When it is used maybe we don't need aclocal's -I parameter anymore.
-AC_CONFIG_MACRO_DIR(m4)
+# Set the path to install-sh
+AC_CONFIG_AUX_DIR(dists/autogen)
# show features and packages in one list
AC_PRESERVE_HELP_ORDER
-# set root directory (= trunk dir)
-# ..resolved: used by configure.ac
-usdxroot=..
-# ..unresolved: used by .in files
-usdxrootdir=\${top_srcdir}/..
-AC_SUBST(usdxrootdir)
-
# set sharerootdir to the resolved dataroot-dir for the config-*.inc file.
# Pascal cannot handle shell-variables like ${prefix}
AC_DEFINE_DIR(sharerootdir, datarootdir)
@@ -82,18 +74,6 @@ AC_DEFUN([AC_SUBST_DEFINE],
AC_SUBST(DEFINE_[$1])
])
-# AC_SUBST_COMMENT(DEFINE_SUFFIX, IS_ENABLED)
-# used to enable/disable lines in a Makefile
-AC_DEFUN([AC_SUBST_COMMENT],
-[
- if [[ x$2 = xyes ]]; then
- COMMENT_[$1]=""
- else
- COMMENT_[$1]="#"
- fi
- AC_SUBST(COMMENT_[$1])
-])
-
# AC_SPLIT_VERSION(VARIABLE_PREFIX, VERSION)
# Splits version number ("major.minor.release") into its components.
# Sets
@@ -278,22 +258,8 @@ AC_ARG_WITH([libprojectM],
[enable projectM visualization support @<:@default=no@:>@])],
[with_libprojectM=$withval], [with_libprojectM="no"])
-# print path options header
-AC_ARG_WITH([cfg-dummy2], [
-Additional directories:])
-
-# add suffix option
-AC_ARG_WITH([suffix],
- [AS_HELP_STRING([--with-suffix=SUFFIX],
- [path suffix @<:@default=ultrastardx@:>@])],
- [suffix=$withval], [suffix="ultrastardx"])
-if [[ x$suffix = xno -o x$suffix = xyes ]] ; then
- AC_MSG_ERROR([Invalid suffix.]);
-fi
-AC_SUBST(suffix)
-
# print misc options header
-AC_ARG_WITH([cfg-dummy3], [
+AC_ARG_WITH([cfg-dummy2], [
Development options:])
LOCAL_BUILD="no"
@@ -307,18 +273,9 @@ AC_ARG_ENABLE(global,
# add local option
AC_ARG_ENABLE(local,
[AS_HELP_STRING([--enable-local],
- [install into local folders (../...) (same as --disable-global) @<:@default=no@:>@]))],
+ [install into local folders (./game/...) (same as --disable-global) @<:@default=no@:>@]))],
[test $enableval = "yes" && LOCAL_BUILD="yes"], [])
-# add dev_layout option
-AC_ARG_ENABLE(dev-build,
- [AS_HELP_STRING([--enable-dev-build],
- [development build (implies local) @<:@default=no@:>@])],
- [enable_dev_build=$enableval], [enable_dev_build="no"])
-if [[ x$enable_dev_build = xyes ]]; then
- LOCAL_BUILD="yes"
-fi
-
# set default Makefile install-target according to local/global build-type
AC_SUBST_DEFINE(USE_LOCAL_DIRS, $LOCAL_BUILD)
if [[ x$LOCAL_BUILD = xyes ]]; then
@@ -332,6 +289,8 @@ fi
# check for compilers
# -----------------------------------------
+AC_CANONICAL_TARGET
+
# find and test the freepascal compiler
# sets PFLAGS, FPC_VERSION, FPC_DEBUG, etc.
AC_PROG_FPC
@@ -426,11 +385,11 @@ PKG_VALUE([libprojectM], [DATADIR], [variable=pkgdatadir], [$libprojectM_PKG],
[projectM data-directory for presets etc. (e.g. /usr/share/projectM)])
# check if we need the c-wrapper
if [[ "$libprojectM_VERSION_MAJOR" -ge 1 ]]; then
- libprojectM_NEEDS_CWRAPPER=yes
+ libprojectM_USE_CWRAPPER=yes
else
- libprojectM_NEEDS_CWRAPPER=no
+ libprojectM_USE_CWRAPPER=no
fi
-AC_SUBST_COMMENT(PROJECTM_CWRAPPER, $libprojectM_NEEDS_CWRAPPER)
+AC_SUBST(USE_PROJECTM_CWRAPPER, $libprojectM_USE_CWRAPPER)
# find portaudio
PKG_HAVE([portaudio], [portaudio-2.0], yes)
@@ -450,12 +409,13 @@ AC_SUBST(LIBS)
# create output files
# -----------------------------------------
-AC_CONFIG_FILES([config-$FPC_PLATFORM.inc:config.inc.in])
AC_CONFIG_FILES([Makefile])
-AC_CONFIG_FILES([$usdxroot/tools/ResourceExtractor/Makefile])
-if [[ x$libprojectM_NEEDS_CWRAPPER = xyes ]]; then
- AC_CONFIG_FILES([lib/projectM/cwrapper/Makefile])
+AC_CONFIG_FILES([src/Makefile])
+AC_CONFIG_FILES([src/config-$FPC_PLATFORM.inc:src/config.inc.in])
+if [[ x$libprojectM_USE_CWRAPPER = xyes ]]; then
+ AC_CONFIG_FILES([src/lib/projectM/cwrapper/Makefile])
fi
+AC_CONFIG_FILES([tools/ResourceExtractor/Makefile])
AC_OUTPUT
# -----------------------------------------