aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c2f4214c..f07cca401 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -796,12 +796,6 @@ endif
libdecoder_a_SOURCES = \
src/decoder/plugins/PcmDecoderPlugin.cxx \
src/decoder/plugins/PcmDecoderPlugin.hxx \
- src/decoder/plugins/DsdiffDecoderPlugin.cxx \
- src/decoder/plugins/DsdiffDecoderPlugin.hxx \
- src/decoder/plugins/DsfDecoderPlugin.cxx \
- src/decoder/plugins/DsfDecoderPlugin.hxx \
- src/decoder/plugins/DsdLib.cxx \
- src/decoder/plugins/DsdLib.hxx \
src/decoder/DecoderBuffer.cxx src/decoder/DecoderBuffer.hxx \
src/decoder/DecoderPlugin.cxx \
src/decoder/DecoderList.cxx src/decoder/DecoderList.hxx
@@ -845,6 +839,16 @@ DECODER_LIBS = \
$(ADPLUG_LIBS) \
$(FAAD_LIBS)
+if ENABLE_DSD
+libdecoder_a_SOURCES += \
+ src/decoder/plugins/DsdiffDecoderPlugin.cxx \
+ src/decoder/plugins/DsdiffDecoderPlugin.hxx \
+ src/decoder/plugins/DsfDecoderPlugin.cxx \
+ src/decoder/plugins/DsfDecoderPlugin.hxx \
+ src/decoder/plugins/DsdLib.cxx \
+ src/decoder/plugins/DsdLib.hxx
+endif
+
if HAVE_MAD
libdecoder_a_SOURCES += \
src/decoder/plugins/MadDecoderPlugin.cxx \
@@ -2061,6 +2065,8 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+if ENABLE_DSD
+
noinst_PROGRAMS += src/pcm/dsd2pcm/dsd2pcm
src_pcm_dsd2pcm_dsd2pcm_SOURCES = \
@@ -2073,6 +2079,8 @@ src_pcm_dsd2pcm_dsd2pcm_LDADD = libutil.a
endif
+endif
+
#
# Documentation