aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/mpd.spec
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2006-07-22 22:01:05 +0000
committerAvuton Olrich <avuton@gmail.com>2006-07-22 22:01:05 +0000
commitc454122a021d705c5ddfa74913d53c18aa078ecb (patch)
tree1b93e7584ad9003ef678b32092d932b8b903a763 /scripts/mpd.spec
parent6dfaa33f376f81fb9650d39a03ca57a46b9aec5a (diff)
downloadmpd-c454122a021d705c5ddfa74913d53c18aa078ecb.tar.gz
mpd-c454122a021d705c5ddfa74913d53c18aa078ecb.tar.xz
mpd-c454122a021d705c5ddfa74913d53c18aa078ecb.zip
- Add a 'scripts' directory, remove scripts from
docs/ & base directory - Add a spec file (my first try, please report problems) git-svn-id: https://svn.musicpd.org/mpd/trunk@4429 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to '')
-rw-r--r--scripts/mpd.spec68
1 files changed, 68 insertions, 0 deletions
diff --git a/scripts/mpd.spec b/scripts/mpd.spec
new file mode 100644
index 000000000..286162a51
--- /dev/null
+++ b/scripts/mpd.spec
@@ -0,0 +1,68 @@
+# the Music Player Daemon (MPD)
+# (c)2003-2006 by Warren Dukes (warren.dukes@gmail.com)
+# This project's homepage is: http://www.musicpd.org
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+# please send bugfixes or comments to avuton@gmail.com
+
+%define _prefix /usr
+%define _share %_prefix/share
+%define _bindir %_prefix/bin
+%define _docdir %_share/doc
+%define _mandir %_share/man
+
+Summary: Music Player Daemon (MPD)
+Name: mpd
+Version: 0.12.0
+Release: 0
+License: GPL
+Group: Productivity/Multimedia/Sound/Players
+Source: ../%name-%version.tar.gz
+#Patch:
+BuildRoot: %{_tmppath}/%{name}-build
+
+%description
+Music Player Daemon is simply a daemon for playing music
+which can be easily controlled over TCP by different
+clients. It has very low CPU usage and can be controlled
+from different machines at the same time.
+
+%prep
+%setup -q
+#%patch -q1 -b .buildroot
+
+%build
+CFLAGS="%{optflags}" \
+CXXFLAGS="%{optflags}" \
+LDFLAGS="%{optflags}" \
+./configure --prefix=%{_prefix}
+make
+
+%install
+make DESTDIR=$RPM_BUILD_ROOT install
+
+%clean
+[ ${RPM_BUILD_ROOT} != "/" ] && rm -rf ${RPM_BUILD_ROOT}
+
+%files
+%defattr(-,root,root)
+
+%{_bindir}/%{name}
+%doc %{_docdir}
+%doc %attr(0444,root,root) %{_mandir}
+
+%changelog
+* Fri Jul 21 2006 Avuton Olrich <avuton@gmail.com>
+- Initial revision