aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-11-30 14:45:56 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-12-02 14:39:52 +0600
commit1df426aa5c571d3d88ecb7bed6b8ed9b32c15e32 (patch)
tree8bacf86f10ec889f91724422930c6e4a742bba81 /configure.ac
parent023482406f9b508e69e6633df4c438903e58c253 (diff)
downloadmpd-1df426aa5c571d3d88ecb7bed6b8ed9b32c15e32.tar.gz
mpd-1df426aa5c571d3d88ecb7bed6b8ed9b32c15e32.tar.xz
mpd-1df426aa5c571d3d88ecb7bed6b8ed9b32c15e32.zip
event: add poll() based PollGroup implementation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d74b0ca6..d24078aab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,7 @@ dnl ---------------------------------------------------------------------------
dnl Event loop selection
dnl ---------------------------------------------------------------------------
+MPD_OPTIONAL_FUNC_NODEF(poll, poll)
MPD_OPTIONAL_FUNC_NODEF(epoll, epoll_create1)
AC_ARG_WITH(eventloop,
@@ -170,7 +171,7 @@ AC_ARG_WITH(eventloop,
AC_ARG_WITH(pollmethod,
AS_HELP_STRING(
- [--with-pollmethod=@<:@epoll|winselect|auto@:>@],
+ [--with-pollmethod=@<:@epoll|poll|winselect|auto@:>@],
[specify poll method for internal event loop (default=auto)]),,
[with_pollmethod=auto])
@@ -202,6 +203,8 @@ if test "x$with_eventloop" = xinternal; then
if test "x$with_pollmethod" = xauto; then
if test "x$enable_epoll" = xyes; then
with_pollmethod=epoll
+ elif test "x$enable_poll" = xyes; then
+ with_pollmethod=poll
elif test "x$host_is_windows" = xyes; then
with_pollmethod=winselect
else
@@ -212,6 +215,9 @@ if test "x$with_eventloop" = xinternal; then
epoll)
AC_DEFINE(USE_EPOLL, 1, [Define to poll sockets with epoll])
;;
+ poll)
+ AC_DEFINE(USE_POLL, 1, [Define to poll sockets with poll])
+ ;;
winselect)
AC_DEFINE(USE_WINSELECT, 1,
[Define to poll sockets with Windows select])